uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
can`t get the script to work!

Knowledge Base Lobby : uStorekeeper Support Conference : Configuration Questions
Jul-22-18 10:55 AM EST
Original Message
can`t get the script to work!
Author plasma on 03-08-2000 at 13:36 (EST)
take a look at this link:

my perl.exe is here: C:Perlbinperl.exe
I am using a NT server.

I have been trying to congure the path at the top at both scripts which needs it


Table Of Contents
  Perl Script Charlie Edmunds, 2000-03-08 21:24:00 (1)
            config trouble Kurt, 2000-03-09 17:13:55 (2)
            CGI Error / executing PL script Martin Zager, 2000-03-14 15:14:54 (3)
                 cgi script Charlie Edmunds, 2000-03-14 18:06:59 (4)
                 RE: CGI Error / executing PL script Bill Weiner, 2000-03-15 14:10:18 (5)

Messages In This Discussion
         1. Perl Script
        Author Charlie Edmunds on 03-08-2000 at 21:24 (EST)

NT Servers don't utilize that path.

I checked out your site and it seems to be working fine. Is it ok now?

Charlie Edmunds
Microburst Technologies, Inc
                 2. config trouble
                Author Kurt on 03-09-2000 at 17:13 (EST)
Yes it solved itself after I copied the into the "lib" directory under perl...
so it works now, but I am not so satisfied with this product, thoug!
I have to have a solution that is more customiseable than this...
Othervise, the admin part and those tools are exellent!
                 3. CGI Error / executing PL script
                Author Martin Zager on 03-14-2000 at 15:14 (EST)
I am having a similiar problem in executing the PEARL script. The CGITest worked fine, but when I try to load storekeeper from the domain:

it doesn't work. It seems to be looking for the library in some other directory rather than the current directory. Here's the error:
CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

Can't locate in @INC (@INC contains: C:/Perl/lib C:/Perl/site/lib .) at

As we don't host our own website, the pearl directory isn't open to the public. Do i have to copy the -lib file to the c:/pearl/lib directory like previous user 'KURT' did or can I simply have the file in the same directory as the rest of the .pl files?
                         4. cgi script
                        Author Charlie Edmunds on 03-14-2000 at 18:06 (EST)

That error usually indicates an incompatible version of perl. Most web hosts have several versions available (and will provide the alternate path when requested). Version 4 is usually best.

Charlie Edmunds
Microburst Technologies, Inc.
                         5. RE: CGI Error / executing PL script
                        Author Bill Weiner on 03-15-2000 at 14:10 (EST)
Based on your error:

"Can't locate"

Is that the correct name for your library file? That is, did you rename the file to ""? (I noticed in your comments that you referred to the file as ""....without the first "sf". So make sure that you indeed have the file named properly.)

And FYI: You should not have to copy the file to your pearl/lib directory since your include directory does have a dot (.) in it...indicating that it will look in the current directory.

So just make sure that you renamed the library properly to match what you renamed it in the script. (


© 2003 Microburst Technologies, Inc.