uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
500 after order is placed

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Jul-22-18 08:48 AM EST
Original Message
500 after order is placed
Author Gerry Campos on 05-16-2000 at 02:52 (EST)
After finishing an order and clicking on "send order" I get a 500 Internal server error. Everything as far as the configuration of the cgi script is correct, the permissions are set, etc.

I do get the orders placed, with email reciept and can see the order number in the server.

Any Ideas on what to check, or what could be wrong?


Gerry Campos

Table Of Contents
  RE: 500 after order is placed Bill Weiner, 2000-05-18 07:11:38 (1)
            500 error Gerry Campos, 2000-05-19 22:49:09 (2)

Messages In This Discussion
         1. RE: 500 after order is placed
        Author Bill Weiner on 05-18-2000 at 07:11 (EST)
So upon pressing the send order button:

1) The order file is written to your "orders" directory.

2) The email receipt is successfully sent to the customer.

3) The email notificiation is successfully sent to the storeowner.

4) But you still get a "Server Error"?

Double-check that you are indeed getting two to the customer and one to the storeowner. I have seen before where the email address configured as the storeowner's email address was causing such a problem. (Why that email address would cause a problem? - perhaps something to do with the DNS mapping on the server and/or the server being setup to only send email to it's own domain....for spamming reasons.)

So as a test, perhaps try using a different email address as the store owner's email address. If that does turn out to be the problem, then you may have to use a different email method, such as:

For UNIX servers:

For NT servers:

                 2. 500 error
                Author Gerry Campos on 05-19-2000 at 22:49 (EST)

Thanks for the help, I took a look at the trouble shoot before but none seemed to fit my problem. Although I did see one that looked familiar to another problem I had with sendmail. I removed the -n and everything worked perfect.



© 2003 Microburst Technologies, Inc.