uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Asking for Login

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Jul-17-18 07:18 AM EST
Original Message
Asking for Login
Author oli on 05-15-2001 at 14:17 (EST)
I have something odd happenning, I am sure it is something I did, but am a little clueless on it.

I have just registered the Ushop, and when I press the Continue button after filling in the personal information page, the perl script just asks for my login.

Table Of Contents
  Re: Asking for Login Joseph Pishgar, 2001-05-15 14:37:51 (1)
            Re: Asking for Login Bill Weiner, 2001-05-15 22:58:12 (2)
                 Closer oli, 2001-05-23 14:53:49 (3)
                      RE: Closer Bill Weiner, 2001-05-23 20:08:26 (4)
                           still nothing oli, 2001-05-24 03:52:50 (5)
                           thinking.... oli, 2001-05-24 21:43:14 (6)
                      Still not meeting security requirements. oli, 2001-05-26 14:23:30 (7)
                           RE: Still not meeting security requirements. Bill Weiner, 2001-05-29 20:24:50 (8)
                                Location Change oli, 2001-05-30 16:44:41 (9)
                                     Hosting Provider oli, 2001-05-30 17:28:56 (10)
                                     email oli, 2001-05-30 20:04:45 (11)
                                          RE: email Bill Weiner, 2001-05-30 22:57:35 (12)
                                               tanking the server oli, 2001-06-12 15:33:39 (13)
                                                    RE: tanking the server Bill Weiner, 2001-06-12 23:04:46 (14)

Messages In This Discussion
         1. Re: Asking for Login
        Author Joseph Pishgar on 05-15-2001 at 14:37 (EST)
Do you mean you are trying to download the script from our site, or you are working with your own site and its doing that?

If the latter is the case, try rechecking your paths in the scripts and template pages, and making sure that they point to the right places as outlined at-

Joseph Pishgar
Support Engineer
                 2. Re: Asking for Login
                Author Bill Weiner on 05-15-2001 at 22:58 (EST)
Another thing to check...

If you are getting all the way to the page where you fill out the order form... but then see the uShop Login page when pressing the "Continue" button on that page... then more than likely, the problem is that the < FORM > HTML tag on your "order_template.html" file accidentally got changed to lower-case. That is, take a look at your "order_template.html" file that is located in your cgi-bin's "data" directory and make sure that the FORM tag near the top of the template is:

< FORM >

and NOT:

< form >

(That particular HTML tag is case-sensative and should be UPPER-CASE).

So check that and if that doesn't resolve the problem, give me the URL and I will take a look at it.
                         3. Closer
                        Author oli on 05-23-2001 at 14:53 (EST)
Well the Upper case solution seems to have been the problem.

The continue button works, but now it directs to a page that says:

Illegal Referrer Page

The referring page did not meet security requirements.

Press BACK To Continue
                                 4. RE: Closer
                                Author Bill Weiner on 05-23-2001 at 20:08 (EST)
At what point in the order process are you seeing the "Illegal Referrer Page" message?

If it is directly after the first "Review Cart" page, then that is where the script will check that the referrer is indeed the URL that was configured in configuration question #3 of the script (the $store_url value).

If it is occurring at some other point in the order process, then that is where the script will check that the referrer is the URL configured in configuration question #4 of the script (the $secure_script_url value). (Especially make sure that the "script_url" parameter of your uShopOrderButton applet EXACTLY matches the $secure_script_url setting in your script).
                                         5. still nothing
                                        Author oli on 05-24-2001 at 03:52 (EST)
I tried these suggestions, but still nothing.

Here is the script URL:

Thank you for your support,

                                         6. thinking....
                                        Author oli on 05-24-2001 at 21:43 (EST)
Now the script seems to be thinking and thinking with no response. (right after the continue button on the page for inputing customer details.)

Eventually the browser says that the script isn't there.

I'm pretty lost on it now.
                                 7. Still not meeting security requirements.
                                Author oli on 05-26-2001 at 14:23 (EST)
I am still getting this error:

Illegal Referrer Page

The referring page did not meet security requirements.

Press BACK To Continue

Perhaps you guys can tell me if this will work for me or not.
                                         8. RE: Still not meeting security requirements.
                                        Author Bill Weiner on 05-29-2001 at 20:24 (EST)
I tried looking at your site to see EXACTLY where you are getting an illegal referrer error, but it appears that the script is not located at your specified "script_url":

(The above URL - which is linked to via your uShopOrderButton applet - results in a "File Not Found" error).

So correct that and then I'll take another look at it.
                                                 9. Location Change
                                                Author oli on 05-30-2001 at 16:44 (EST)
My hosting company removed the script as they said it was constantly running in the background. Somehow it was chewing up their server processor. They said that they have about 100 sites on that server and the script is taking up about 80-90% of the processor time. :(

We have just moved it over to another unix server with a cobalt box at and the script is located at .

The problem is that when you press the continue button on the page for customer details, it just thinks and thinks and thinks. Nothing happens.

Thanks for the help Bill. I hope it can be resolved quickly, I'm hoping to have this up and running soon.

                                                         10. Hosting Provider
                                                        Author oli on 05-30-2001 at 17:28 (EST)
I just talked to the hosting provider about the script. They said that the script is chewing up processing time at the point that the continue button on the customer details page is pushed.

They said it was eating up 134 megs and it was increasing with every second before they shut it down. We are still testing this all on the www2 space.

They did say that the script was looking for a file called ushop-settings.txt in the data directory, but there is none there.

Does this make sense?
                                                         11. email
                                                        Author oli on 05-30-2001 at 20:04 (EST)
If you need to take a closer look, email me and I'll send you the FTP/telnet codes to enter the site.
                                                                 12. RE: email
                                                                Author Bill Weiner on 05-30-2001 at 22:57 (EST)
Two things:

1) The uShop CGI script does utilize a file called "ushop-settings.txt" ... which should have been created in your data directory the first time you logged in to the uShop Control Panel and configured the general settings. Have you done that? (Note: Regardless of whether the "ushop-settings.txt" file exists or not...that will NOT be causing the script to lock up.)

2) If you say the script is continuously running after the user enters his/her billing/shipping information, then there may be a problem with your "order_template.html" file. Have you modified that file at all? I would suggest trying the standard "order_template.html" file that is distributed with uShop. Just transfer the default "order_template.html" file to your server (in ASCII mode) ... and see if that resolves your problem.
                                                                         13. tanking the server
                                                                        Author oli on 06-12-2001 at 15:33 (EST)
sorry it has been so long since I have been on this project.

Because of the time it has taken, I have informed the client that this will take a lot longer than originally thought, as I have had to complete some other projects.

My hosting company has put it on a different location, while we test it out.

I have reloaded the original order_template file, and still the servers tank out.

The tech guys with my hosting company would like to speak to one of you directly to find the problem, if you are willing. Just email me for the contact info.

                                                                                 14. RE: tanking the server
                                                                                Author Bill Weiner on 06-12-2001 at 23:04 (EST)
If you submit a support request with your FTP information, I'll take a look at your configuration.

Also include any other questions you/your hosting provider may have in the support request.

© 2003 Microburst Technologies, Inc.