uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Server error on trying to access

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Jul-23-18 07:57 AM EST
Original Message
Server error on trying to access
Author Andy Wilson on 04-16-2001 at 11:02 (EST)
I've uploaded to my gci-bin but get 'Server Error' message when trying to access the script through my browser. I've checked that the file permissions are 755.

Table Of Contents
  Re: Server error on trying to access Joseph Pishgar, 2001-04-16 12:06:28 (1)
   Andy Wilson, 2001-04-16 12:31:57 (2)
                 RE: Bill Weiner, 2001-04-17 06:40:31 (3)
             problems Andy Wilson, 2001-04-17 10:36:56 (4)
                           RE: problems Bill Weiner, 2001-04-18 06:22:14 (5)
                                pl files Andy Wilson, 2001-04-19 03:43:29 (6)
                                     RE: pl files Bill Weiner, 2001-04-19 05:22:18 (7)
                                          2 further queries Andy Wilson, 2001-04-19 08:32:15 (8)
                                               Clarification of last message Andy Wilson, 2001-04-19 09:31:01 (9)
                                                    RE: Clarification of last message Bill Weiner, 2001-04-20 05:59:25 (10)

Messages In This Discussion
         1. Re: Server error on trying to access
        Author Joseph Pishgar on 04-16-2001 at 12:06 (EST)
Try CHMODing it to 777 and see if that works.
Did make double sure that you uploaded it in ASCII format?
                Author Andy Wilson on 04-16-2001 at 12:31 (EST)
Tried 77 and get the message 'Incorrect permissions'
Checked ASCII upload also.
                         3. RE:
                        Author Bill Weiner on 04-17-2001 at 06:40 (EST)
The only things that can be causing a server error are the three items listed in Section 2 on this troubleshooting page:

Also, 3 questions:

1) What type of server do you have Unix or Windows?

2) What is the URL of your script... so that I can see the exact error message that you are getting?

3) Have you tried installing this test script:

... in order to make sure that your account is configured to run CGI scripts?
                                 4. problems
                                Author Andy Wilson on 04-17-2001 at 10:36 (EST)
Thanks for the swift response and suggestions. Support is very good for this product as I found when getting version 2 working.
I've successfully run the test script. My server have got the script working saying it should have been transferred in Binary mode (against your instructions). They apparently did this by telnet and giving the command dostou
However, if I try to go to the other .pl scripts I still get the error messages. e.g.
                                         5. RE: problems
                                        Author Bill Weiner on 04-18-2001 at 06:22 (EST)
Yes, some servers require that you run a "dos2unix" utility on any scripts transferred over to it from a Windows machine.... And that's why we suggest installing that test script... so that you can find out if there are any such special things that need to be done on your server in order to get scripts to run.

Anyway, it sounds like you have it running now. That is, I see that you successfully get the login screen at the URL:

The URL of the library:

.... will generate an error because it will have no output. You never need to refer to that URL directly... but instead should just use your URL.

So try logging in to your control panel and see if everything is working for you.
                                                 6. pl files
                                                Author Andy Wilson on 04-19-2001 at 03:43 (EST)
I can now login and change settings successfully. I'm still having problems with OrderButtonClass being blank and have looked at troubleshooting on that subject without success. I'll do some more work on that before posting another request.
Just one note on the script. This worked fine first time after transferring to the cgi-bin so therefore didn't show any of the subsequent problems with the other scripts requiring dos to unix conversion.
                                                         7. RE: pl files
                                                        Author Bill Weiner on 04-19-2001 at 05:22 (EST)
Let us know if you need assistance with the uShopOrderButton (By the way, if the problem is that the image is not being displayed then it may just be that the image is not located in your classes directory).

In regard to the script working without running dos2unix... it may have been because you downloaded the file directly from our Unix server. If you used the file that was included in the file... then that may have required the dos2unix utility. In any case, glad you got it working.
                                                                 8. 2 further queries
                                                                Author Andy Wilson on 04-19-2001 at 08:32 (EST)
Regarding the order template file in the unzipped cgi-bin. When I try to open it in my web design package (Hot Metal) I'm getting the message 'There is a problem with the attributes in the following tag . If you continue it will be changed to . It then gives me the options of saying 'Yes' to this change , going to the source code to fix it or ' Cancel' Any ideas why this is coming up?
Secondly, on the 'ShopOrderButton' applet I'm getting the image O.K. but when I click on 'Begin the Order Process' I get a very brief 'Please Wait' followed by a blank screen. I'm using the default codebase and have made sure the final / is included.
This is all in the Hotmetal browser in which the demo site works fine.
                                                                         9. Clarification of last message
                                                                        Author Andy Wilson on 04-19-2001 at 09:31 (EST)
Some of the last message didn't get displayed. The tag the Hotmetal browser is having problems with is USHOP INSTRUCTIONS and the software wants to change it to USHOP.
                                                                                 10. RE: Clarification of last message
                                                                                Author Bill Weiner on 04-20-2001 at 05:59 (EST)
Reply posted at:

© 2003 Microburst Technologies, Inc.