uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Won't save user

Knowledge Base Lobby : uSignIn Support Conference : General Troubleshooting
Aug-15-18 12:07 AM EST
Original Message
Won't save user
Author Chris on 03-25-2003 at 14:01 (EST)
I got the script all setup and running and it appears to be working, but whenever i go to add new user, i put in all the info, and click save and it says it saves, but the user never shows up. Any ideas?

Table Of Contents
  RE: Won't save user Bill Weiner, 2003-03-26 06:49:35 (1)
            RE: Won't save user Chris, 2003-03-27 11:56:59 (2)
                 RE: Won't save user Bill Weiner, 2003-03-28 06:47:07 (3)
                      RE: Won't save user Chris, 2003-04-01 12:36:30 (4)
                           RE: Won't save user Bill Weiner, 2003-04-02 06:35:52 (5)
                                RE: Won't save user Chris, 2003-04-03 10:42:00 (6)

Messages In This Discussion
         1. RE: Won't save user
        Author Bill Weiner on 03-26-2003 at 06:49 (EST)
Near the top of the usignin.cgi script, try adding the directory path to the files specified in Configuration Question #11.

That is, try changing configurion question #11 from:

$user_database = "usignin.csv";
$msg_database = "messages.csv";

... To something like:

$user_database = "/www/youaccount/cgi-bin/usignin.csv";
$msg_database = "/www/youaccount/cgi-bin/messages.csv";

Where the "/www/youaccount/cgi-bin/" is actually the full directory path for your server. (Would be different based on your Server OS and directory structure.)

Specifying the full directory path in front of those ".csv" file names will ensure that the files are actually being written/read to/from you intend and may resolve the problem.
                 2. RE: Won't save user
                Author Chris on 03-27-2003 at 11:56 (EST)
I tried changing what you said and it still does the same thing. I tried different directories also. Got anymore ideas? This is running off a W2K machine and i don't really know much about perl or any scripts for that matter, so maybe i have some setting wrong somewhere?
                         3. RE: Won't save user
                        Author Bill Weiner on 03-28-2003 at 06:47 (EST)
Since you're using a Win2k machine, when specifying the paths that I mentioned above, did you rememeber to "escape" the backslashes? Something like this:

$user_database = "c:\www\youaccount\cgi-bin\usignin.csv";
$msg_database = "c:\www\youaccount\cgi-bin\messages.csv";

Or on Win2k, non-escaped forward slashes will work:

$user_database = "c:/www/youaccount/cgi-bin/usignin.csv";
$msg_database = "c:/www/youaccount/cgi-bin/messages.csv";

After getting the above paths set correctly for your server, take a look on your server and verify that the "usignin.csv" and "messages.csv" files have actually been created (after your first attempt to add a user) where you expect them to be created. Also verify that they are not read-only.
                                 4. RE: Won't save user
                                Author Chris on 04-01-2003 at 12:36 (EST)
OK, i tried both those formats for the path (I was using the forward slashes before) and neither works, same thing happens. The files are being created and i have deleted them and let it recreate them a few times. The files are not set to read-only, the directories have all permissions except delete files. Got anymore ideas?
                                         5. RE: Won't save user
                                        Author Bill Weiner on 04-02-2003 at 06:35 (EST)
When users are created, temporary files are created, renamed and deleted... so try enabling all permissions for now and see if that resolves the problem.
                                                 6. RE: Won't save user
                                                Author Chris on 04-03-2003 at 10:42 (EST)
OK, that did it. Appearently "Everyone" needs all rights except change permissions and take ownership. Well, it works now though. We'll look into it and see what we think. Thanks for your help.

© 2003 Microburst Technologies, Inc.