uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Udirectory "Unable to open"

Knowledge Base Lobby : uDirectory Support Conference : General uDirectory Troubleshooting
Aug-19-18 12:04 PM EST
Original Message
Udirectory "Unable to open"
Author Ron N on 03-31-2000 at 21:19 (EST)
I have been trying to set up Udirectory for 6 hours so far and had simular fun with Ushop.

I have set up the cgi-bin and the listings folder and can log onto the Admin Interface. I can configure the listings as the first step. Then it will allow me to create a category. Then when I go to add a listing it allows me to view the listing with the image I have selected the when I go to submit i get:

Unable to open c:/inetpub/wwwroot/listings/udirectory-configuration.txt
I have tried all the different way to point to the listings directory such as ../listings/ / c:inetpub/wwwroot/listings/

I do have udirectories-categories.txt and udirectory-configuration.txt in the listings directory, so I can write to it but it cant access the folders inside.

Any suggestions.


Table Of Contents
  uDirectory Charlie Edmunds, 2000-04-01 13:42:16 (1)
            Configuration Issues Ron N, 2000-04-01 21:12:55 (2)
                 config issues Charlie Edmunds, 2000-04-02 20:58:05 (3)
                 Config Udirectory Ron N, 2000-04-03 02:48:24 (4)
                      RE: Config Udirectory Bill Weiner, 2000-04-03 19:57:33 (5)

Messages In This Discussion
         1. uDirectory
        Author Charlie Edmunds on 04-01-2000 at 13:42 (EST)

Be sure that you are using an url for:
$html_url = "";

and a path for:
$html_directory = "/www/htdocs/listings/";
note: you may have to get the path from your host. Especially if you want to use the entire path like: d:inetpubwwwrootaccountsur_domain_rootlistings

Are you sure that your permissions are set correctly?

If you still have trouble give me an url to your host so I can see some their support info. Also what OS are you hosted on, NT, Unix? What kind of tool are you using to verify/set permissions.

Thanks, Charlie Edmunds
Microburst Technologies, Inc.

                 2. Configuration Issues
                Author Ron N on 04-01-2000 at 21:12 (EST)
In your suggestion above you are using backslashes, my address is this

should I use backslashes or forward?

the complete URL to the directory is:

$html_url = "";

I am a Service provider so I am setting up the server which is NT and I am setting the permissions in NT Explorer
                         3. config issues
                        Author Charlie Edmunds on 04-02-2000 at 20:58 (EST)
I'm sorry,

Yes, you're correct, you should use forward slashes. Using that configuration with the proper permissions should work. Let me know.

Charlie Edmunds
Microburst Technologies, Inc.
                         4. Config Udirectory
                        Author Ron N on 04-03-2000 at 02:48 (EST)
I have tried everything and to no avail.
Do you have to generate the html files yourself with the html utility, as all the files it sends to the directory are .txt?

Have you ever heard of a situation where sometimes it will write to the directory and sometimes it wont?

The directory contains the files, which are included in the attachment (I sent you a screenshot of the directory via email) so it can write to the directory sometimes.
We have checked the security on the server and it is the same as with the Ushop, which is working…. This is strange and frustrating.

I hope you can help
                                 5. RE: Config Udirectory
                                Author Bill Weiner on 04-03-2000 at 19:57 (EST)
I just replied to your support request so check that...but just noticing your post here, I see how you mention that you have txt files but no html files. (The html files will be created automatically as you create categories and add listings to them.)

This really makes it sound like a permissions problem.

That is, do you also have many tmp files in your listings directory? If so, then the problem may be something I've seen before where the directory on the NT server had permission to read, write, and delete files....but for some reason it was not allowing scripts to 'rename' files. (uDirectory will try to rename those tmp files to html files once it is done creating the files). The problem was corrected by opening up the permissions on that directory even more. So try opening the permissions on that directory all the way and see if it corrects the problem.

© 2003 Microburst Technologies, Inc.