uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
display_product template_product

Knowledge Base Lobby : uShop Support Conference : General Questions
Aug-21-18 12:54 AM EST
Original Message
display_product template_product
Author Lutz on 10-05-2000 at 17:59 (EST)
I tried to use a flat file with the ushopsearch1 applet to generate pages automatically. It only produces an empty page.

I am using the flat file and the templates that came with the zip file. All keywords are present on the template_product file. No codebase error.

Another question comes to mind:

Where do I put in the info which input applet I want to use for the generated page?

Thanks for your help!

Table Of Contents
  RE: display_product template_product Bill Weiner, 2000-10-06 05:36:26 (1)
            product_template Lutz, 2000-10-09 12:26:58 (2)
                 RE: product_template Bill Weiner, 2000-10-09 16:04:55 (3)
                      product_template Lutz, 2000-10-10 14:06:58 (4)

Messages In This Discussion
         1. RE: display_product template_product
        Author Bill Weiner on 10-06-2000 at 05:36 (EST)
Have you tried the Search/Browse applets straight out of the applet reference that was installed on your local computers when you unzipped/installed uShop 3.0? And if so, did they work when ran off of your local desktop computer?

If they didn't work for you as-is, then are you seeing any error messages in your browser's status bar and/or Java console? That is, you may be running into a problem that we have had a few other reports about. Apparently some people when trying to run those applets off of their local desktop computer get some "security exception" error. We think this may be related to the browsers search paths on your local desktop computer but are still looking into it. In any case, those Seach/Browse applet should run fine for you as soon as you put them on your server and try them out from there.

Otherwise, if the Search/Browse applets did work as-is from your local desktop computer...but are not working in the new pages that you are developing, I'll need more information about your directory structure and HTML. Give me a test URL where I can take a look at it ... or send the info/html to us as


In regard to controlling which applet(s) is(are) used on the dynamically generated pages of the Search/Browse applets, at this time, those applets will be the uShopInput1, uShopInput3, uShopInput4, or uShopInput5 applets.... depending on the whether each item the data file has any options or not.
                 2. product_template
                Author Lutz on 10-09-2000 at 12:26 (EST)
- Yes I have tried the search applet straight out of the reference installed on my local computer and the applet is working.

- When I run the search applet following error message appears at the bottom (Netscape only-IE shows only an empty page): ushopJSI stopped

- I put the applets on our server, the result is the same.

I will send two urlīs by e-mail so that you can check it out.


                         3. RE: product_template
                        Author Bill Weiner on 10-09-2000 at 16:04 (EST)
From looking at your test site, I see that upon doing a search with the uShopSearch applet, the following error is displayed in the Java Console:

uShop Message: Error reading template_product

So then I took a look at your HTML at it appears the "product_template" parameter of your search applet is missing the ".html".

So try changing the value of that parameter to:


And that should correct the problem.
                                 4. product_template
                                Author Lutz on 10-10-2000 at 14:06 (EST)
That was it. Thanks again for your quick help!

© 2003 Microburst Technologies, Inc.