uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Problems with the cgi script for 3.0 can send orders

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Jul-17-18 11:22 AM EST
Original Message
Problems with the cgi script for 3.0 can send orders
Author Kridaraan on 10-14-2000 at 06:27 (EST)
CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

Can't locate D:/www/ in @INC (@INC contains: d:/Perl/lib d:/Perl/site/lib .) at line 52.

it can be checked at: . Please help me. This is really important to our company! I would like to know if chmod is needed. If yes, what is it? I would really appreciate your help.

Table Of Contents
  RE: Problems with the cgi script for 3.0 can send orders Bill Weiner, 2000-10-14 14:21:11 (1)
            Still can't Kridaraan, 2000-10-17 01:19:45 (2)
                 RE: Still can't Bill Weiner, 2000-10-17 06:19:07 (3)
                      Doesn't work Kridaraan, 2000-10-18 02:42:08 (4)
                           RE: Doesn't work Bill Weiner, 2000-10-18 05:16:42 (5)

Messages In This Discussion
         1. RE: Problems with the cgi script for 3.0 can send orders
        Author Bill Weiner on 10-14-2000 at 14:21 (EST)
Based on your "Can't locate D:/www/" error, see item number 7 on the following troubleshooting page:

That will solve the problem.
                 2. Still can't
                Author Kridaraan on 10-17-2000 at 01:19 (EST)
I have tried that way which is putting the full path as shown in the example. But i still can't get it working. I'm using NT server.
                         3. RE: Still can't
                        Author Bill Weiner on 10-17-2000 at 06:19 (EST)
From going to your script at:

I can see that you are now getting the error message:

"Can't locate D:/www/"

That is, it looks like you have configuration question #11 set to:

require "D:/www/";

Are you sure that is the correct path for your server? Based on your error messages, I would guess you should be using:

require "e:/user/";
                                 4. Doesn't work
                                Author Kridaraan on 10-18-2000 at 02:42 (EST)
I've tried using e: but it still doesn't seem to work. You can check it at: .
And i would also like to know if i must chmod a folder like the version 2.0 one. We need to finish this order project by next thursday and i will get real scolding from my manager for wasting money getting this program which doesn't work. I really need your help and this is urgent!
S.O.S. I've also spent lots of time setting up the store and the only damn thing that isn't working is the cgi. Can i've your e-mail add? I can send you the cgi and you can inspect it. Would that be fine? Or is it better checking it online. I really need a reply as soon as possible. This is very important to our business!

                                         5. RE: Doesn't work
                                        Author Bill Weiner on 10-18-2000 at 05:16 (EST)
By going to your script at:

I see you are now getting different error messages such as:

"not returning a complete set of HTTP headers"
"Bareword found where operator expected"
"syntax error near near "$settings_file = $data_directory . "ushop"
"Missing semicolon on previous line"

Which definitely means you made an error while configuring the script... most likely by in configuration question #6...which shouldn't be modified anyway.

If you want, send your "" file to and I will take a look at your configuration questions.

© 2003 Microburst Technologies, Inc.