uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
What have I missed when implementing full version?

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Jul-19-18 11:33 AM EST
Original Message
What have I missed when implementing full version?
Author Nick Kay on 09-07-2000 at 16:18 (EST)

1. Had full site running with trial version
2. Tested by other users
3. Purchased Full version
4. Unzipped
5. Copied cgi, data, classes
6. Uploaded (binary for .classes)
7. Site comes up
8. Press start order button
9. Please wait
10. Blank screen...

What have I missed?

Table Of Contents
  RE: What have I missed when implementing full version? Bill Weiner, 2000-09-08 12:31:14 (1)
            Oh no... Nick Kay, 2000-09-11 03:38:22 (2)
                 RE: Oh no... Bill Weiner, 2000-09-11 09:17:12 (3)
                      :( Nick Kay, 2000-09-11 14:19:47 (4)
                           RE: :( Bill Weiner, 2000-09-11 14:29:38 (5)
                                Weird... Nick Kay, 2000-09-11 19:46:28 (6)
                                     Sorted once and for all ??? Nick Kay, 2000-09-12 07:56:34 (7)

Messages In This Discussion
         1. RE: What have I missed when implementing full version?
        Author Bill Weiner on 09-08-2000 at 12:31 (EST)
Oh no! Isn't that the same error we started with last time? :)

I just took another look at your site.... and it kind of looks like either the "template_cart.html" and/or the "display_cart.html" files were not successfully transferred to the classes directory on your server. So double-check them.
                 2. Oh no...
                Author Nick Kay on 09-11-2000 at 03:38 (EST)
Hi Bill

No, I checked the template files etc are in the classes directory :(
                         3. RE: Oh no...
                        Author Bill Weiner on 09-11-2000 at 09:17 (EST)
Well, from looking at the following page in your classes directory:

It appears that for some reason it is missing the entire "DisplayCartHTML" JavaScript method. So I would suggest getting a fresh copy of that "display_cart.html" page from the uShop .zip or .exe file... and then re-transfering it to your server.
                                 4. :(
                                Author Nick Kay on 09-11-2000 at 14:19 (EST)
Tried that, still have the fault
                                         5. RE: :(
                                        Author Bill Weiner on 09-11-2000 at 14:29 (EST)
When I go to the URL:

I can still see that your "display_cart.html" page is missing the "DisplayCartHTML()" JavaScript function. In fact, if you view it with Netscape, you'll see a "DisplayCartHTML is not defined." JavaScript message..... so take a closer look at that.

If still don't see the problem the, send us an email at "" with your "display_cart.html" file attached.... and I will take a look at it.
                                                 6. Weird...
                                                Author Nick Kay on 09-11-2000 at 19:46 (EST)
Hi Bill

The templates and display_xxx are straight out the zip file - no changes made at all!!!

I'll email the display_xxx's to you to check...
                                                         7. Sorted once and for all ???
                                                        Author Nick Kay on 09-12-2000 at 07:56 (EST)
Hi Bill

I think its now all sorted - resolution may assist others...

1. Spoke with my service provider. Found someone to look at the .pl scripts on the server - they'd got extraneous characters!!!

2. I thought I'd checked for this by sending them up to the server & then bringing them back.

3. I'm using HotDog6 at my Editor and had tried it's FTP software and had also been using Laplink FTP (both uploading in text mode).

4. Have swapped to FTP Surfer & problem has disappeared.

Moral of the story seems to be "you're not necessarily seeing what your seeing" - check your FTP software...

© 2003 Microburst Technologies, Inc.