uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Aug-20-18 10:48 PM EST
Original Message
Author jalina on 06-03-2000 at 11:44 (EST)
Please, I need some help with this script. I have read almost ever post I could find and have not see a similar error to the one I am getting. I have tried every way I can think of to try and get this to work but I always get this msg.....
What is it that I am doing wrong?
Thank you for your help.

You are not authorized to view this page
You might not have permission to view this directory or page using the credentials you supplied.


If you believe you should be able to view this directory or page, please try to contact the Web site by using any e-mail address or phone number that may be listed on the www.(sitename).com home page.

You can click Search to look for information on the Internet.

HTTP Error 403 - Forbidden
Internet Explorer

Table Of Contents
  RE: ushop_cgiscript.cgi Bill Weiner, 2000-06-03 16:44:05 (1)
            ushop_cgiscript.cgi jalina, 2000-06-03 22:51:51 (2)
                 RE: ushop_cgiscript.cgi Bill Weiner, 2000-06-04 07:10:45 (3)

Messages In This Discussion
         1. RE: ushop_cgiscript.cgi
        Author Bill Weiner on 06-03-2000 at 16:44 (EST)
It sounds like your server/account may not be setup to execute Perl CGI scripts. As a test, try installing the very basic Perl script described at:

This test script is actually on the reference pages for one of our other products (called
uStorekeeper), but the concept is the same. By following the instructions to install this very
basic Perl script, you should be able to see how Perl scripts are installed/executed on your
server, as well as verify that your account is setup properly to execute Perl scripts. Once you
get that test script working....installing the uShop CGI script should be much easier.
                 2. ushop_cgiscript.cgi
                Author jalina on 06-03-2000 at 22:51 (EST)
Thank you for responding to my letter. I did the test that you gave, and I get the same msg. As far as I know the server does accept cgi because they have a url that I read over, almost like a "what did I do wrong". I can give you the url if you would like to take a look at it. I am really lost and thank you very much for your help.
                         3. RE: ushop_cgiscript.cgi
                        Author Bill Weiner on 06-04-2000 at 07:10 (EST)
If you want to give me the URL of the test script, I'll take a look at it and see if I can figure anything out from the error message....but really, since that test script is about the most basic Perl script there is, if it is not working on your server, then your account may not be setup to execute Perl scripts.

What I would suggest doing is double-checking the configuration of the test script one more time by:

1) Making sure the very first line of the script has the correct path to Perl. (It will be something #!/usr/bin/perl ... don't forget the #! in front.)

2) Transfering it to your cgi-bin on your computer by using ASCII transfer mode (as opposed to BINARY transfer mode).

3) Giving the script execute permissions by doing a chmod 755 on the script (using your FTP program).

And with that very basic Perl script, these are the only things that could be causing a problem on your side. So once you double-check all of these things and you see that you are still getting the same error with the test script, then that pretty much confirms that your account is not setup to execute Perl scripts. You should then just contact your web hosting provider, tell them that you have a very basic test script that you are trying install/execute, but are getting an error. They should then be able to see the problem and help you out.


© 2003 Microburst Technologies, Inc.