uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Unable to open /orders/U199749858

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Jul-23-18 01:35 PM EST
Original Message
Unable to open /orders/U199749858
Author Jeff Cashman on 12-31-1999 at 12:24 (EST)
I'm on an NT4 server, and am getting the error message:

File Error

Unable to open D:/web/mysite/cgi-bin/mcdorders/U199749858

I've tried writing directly to the cgi-bin, different paths to the orders directory, and finally the absolute path above. Still the same error.

I read the FAQ about the IIS4 permssion issue from a user, though it is a bit sketchy, so I installed the cgi and a test page on another account with the same ISP which uses IIS3 - same exact error, this time with the absolute url to the secondsite/cgi-bin/orders/#

I've asked them about different ways they might set permissions, and it hasn't helped.

-Can you suggest exactly what I should request my ISP to do?
(I would really like to stay with my ISP if possible)

-If they have unix machines, would moving to one of them resolve my problem?

-Can you suggest a list of NT hosts which run your shopping cart cgi-script successfully?


Table Of Contents
  also... jc, 1999-12-31 12:28:32 (1)
  orders directory charlie edmunds, 1999-12-31 17:40:41 (2)
            tried 2, 3, 4 and still a no-go Jeff, 2000-01-01 16:59:58 (3)
                 Permissions charlie edmunds, 2000-01-02 08:23:44 (4)
                      "permissions" Jeff, 2000-01-03 21:41:09 (5)
                           got it - thanks! Jeff, 2000-01-04 17:59:25 (6)
                                Unable to open folder ./order/ Edward, 2000-03-01 17:24:06 (7)
  Host Problems charlie edmunds, 2000-03-01 18:24:02 (8)

Messages In This Discussion
         1. also...
        Author jc on 12-31-1999 at 12:28 (EST)
I should have also mentioned that I have a links cgi directory on the IIS 3 server test installation above -- same cgi-bin -- which has no errors writing files and directories under that account/cgi-bin. I don't understand why the write/execute permssions would work for links but not for your cgi-script???
         2. orders directory
        Author charlie edmunds on 12-31-1999 at 17:40 (EST)

Check out this link. It is from our reference site which contains a wealth of info about setting up uShop.

fixes 2 and 3 seem most likely ...

uShop runs on NT Server/IIS or Unix just fine. You should have no trouble getting uShop to work on whatever your host is running.

Charlie Edmunds
Microburst Technologies, Inc.
                 3. tried 2, 3, 4 and still a no-go
                Author Jeff on 01-01-2000 at 16:59 (EST)
My host is

I will talk with them on Monday, but wanted to see if there were any specifics regarding 6 since I can't ask them to "make it work" until I understand why it doesn't.

I can write even to dynamically created directories under my cgi-bin with other perl scripts as noted above, and I still don't understand why one perl script would react differently to the same permissions than another?

Thanks for the reply.
                         4. Permissions
                        Author charlie edmunds on 01-02-2000 at 08:23 (EST)

How are you determining what the permissions are?

If you have a unix account you can check and change them yourself. If you are on NT then you are not going to be able to check/change them yourself (even thought WS-FTP appears to be making the changes).

Charlie Edmunds
                                 5. "permissions"
                                Author Jeff on 01-03-2000 at 21:41 (EST)
So having another perl script that *will* create files and writable directories under a cgi-bin *is not* verification that the cgi-bin has WRITE and EXECUTE permissions? (e.g. Matt's Script Archive WebBBS)

To be clear, you are saying that some perl scripts will *get around* incorrectly set permissions that will keep the Ushop script from writing?

I assume the absolute path D:/web/mydomain/cgi-bin/orders/ is the best one to set, provided it is correct.

I have asked interactive-internet to set WRITE and EXECUTE permissions, and really like their hosting, almost as much as the java portion of your shopping cart, but need to understand this before I tell them that "they're doing it wrong".
                                         6. got it - thanks!
                                        Author Jeff on 01-04-2000 at 17:59 (EST)
I still don't understand what the permissions error was, but when the main guy at my ISP got back from the holiday today, he got it working in 10 minutes.

Sorry to be such a pain while I was dealing with the other guys there : )
                                                 7. Unable to open folder ./order/
                                                Author Edward on 03-01-2000 at 17:24 (EST)
I am running an NT box at home. I have applied all of the techniques described in the Troubleshooting, however, I continue to receive the same error. Please let me know the advice given to the ISP to resolve this problem. Thank You, Edward
         8. Host Problems
        Author charlie edmunds on 03-01-2000 at 18:24 (EST)
Jeff Cashman,

That error usually is a permissions problem. You definately should not have to write to a path either. What are you using to verify/set permissions. On an NT host you (normally) cannot set them yourself and have to have the host do it. On a unix host you can verify/set them with an FTP utility like WS-FTP.

The ushop script is not complicated and runs fine on either NT or unix hosts. I wouldn't change hosts .... yet. Your cgi-bin needs read/exe permissions and the orders directory needs the write permissions, in other words you should not be able to write to the cgi-bin, just the orders directory.

Take a look at this info:
there is a section on cgi troubleshooting. It should also be a help.

Charlie Edmunds
Microburst Technologies, Inc.

© 2003 Microburst Technologies, Inc.