uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
installation questions

Knowledge Base Lobby : uDirectory Support Conference : uDirectory Configuration Questions
May-25-19 08:31 PM EST
Original Message
installation questions
Author Timothy Cawein on 09-12-2000 at 16:04 (EST)
I have tried with out any success to get this working.
I am trying to get this up and running on a unix server running apache 1.3.0

Our current directory structure looks like this:

/apache_1.3.0/ (contains the following dir)
/cgi-bin (where I placed udirectory_personal.cgi)
/docs (this is where our HTML pages are located)
/docs/listings was created as per instructions

I did a chmod on the cgi script to 755 & set the listings dir to 777 (see dir info below)

When I try to run the script I get a message that /listings/listings-A.html couldn't be opened. The install instructions mention the directory locations & rights (which I believe are correct)

Maybe I've looked at too long today. Any help or suggestions would be appreciated.

Item # 2 relative directory is set for ../listings/

Itme # 3 directory url is set to

I am running frontpage extensions on this web server. I don't know if that makes any difference at all.

This is the info on the cgi script:
-rwxr-xr-x 1 cawein nobody 46037 Sep 12 16:50 directory.cgi

This is the info on the listings dir
drwxrwxrwx 2 cawein nobody 512 Sep 12 16:36 listings

Table Of Contents
  RE: installation questions Bill Weiner, 2000-09-13 07:00:31 (1)
            Re: Installation Question Timothy Cawein, 2000-09-14 12:38:26 (2)
                 Works! Timothy Cawein, 2000-09-14 15:34:49 (3)
                      file error john middlebrook, 2001-06-02 15:01:13 (4)
                           RE: file error Bill Weiner, 2001-06-05 21:31:06 (5)
                                I got the same problem! Paul Pittman, 2003-01-09 21:47:20 (6)
                                     RE: I got the same problem! Bill Weiner, 2003-01-10 06:33:30 (7)

Messages In This Discussion
         1. RE: installation questions
        Author Bill Weiner on 09-13-2000 at 07:00 (EST)
Since you mention that the "listings" directory has been created and given the appropriate permissions, the only thing left that could be causing the problem is the relative directory path from your cgi-bin to your "listings" directory.

Based on the directory structure information that you provided, in configuration question #2, instead of using:

$relative_directory = "../listings/";

Try using

$relative_directory = "../docs/listings/";

... and I think that will work for you.

Otherwise, try using a full directory path to your "listings" directory.
                 2. Re: Installation Question
                Author Timothy Cawein on 09-14-2000 at 12:38 (EST)
That's something I was debating, but I wasn't sure if it could work thru the directory structure like that, since the CGI-BIN Directory was indepenent of the HTML Docs directory (I thought for the purposes of the web server they were sort of by themselves & didn't know what was inbetween them.

I'll give it a try & see what happens.

                         3. Works!
                        Author Timothy Cawein on 09-14-2000 at 15:34 (EST)
That fixed it.

Thank you!!
                                 4. file error
                                Author john middlebrook on 06-02-2001 at 15:01 (EST)
i tried everything mentioned above and even tried to set the relative path to absolute

/home/mulanoc/public_html/listings/ and still get the unable to open

/home/mulanoc/public_html/listings/listings_A.html error

listings dir is 777
cgi file (i renamed the pl to cgi to try to make it easier for my server) 755

what else might be wrong

address is

thanks guys

                                         5. RE: file error
                                        Author Bill Weiner on 06-05-2001 at 21:31 (EST)
Any unable to open listings_A.html error will really be caused by either:

1) The "listings" directory not having WRITE and EXECUTE permissions.


2) The path that you are using to your "listings" directory is incorrect.

So double-check that you did give your "listings" directory 777 permissions.... and double-check that "/home/mulanoc/public_html/listings/" is indeed the correct path to your listings directory on your server.

If this doesn't resolve the problem, FPT to your server and see if any files have been created in your "listings" directory.
                                                 6. I got the same problem!
                                                Author Paul Pittman on 01-09-2003 at 21:47 (EST)
tried everything listed above (FTP, CHMOD both 777 and 666 just in case, complete, partial and truncated path) still same error
Unable to open ../d:/home/Default/

A little frustrating since I was thinking this program might have been the script we were looking for!
                                                         7. RE: I got the same problem!
                                                        Author Bill Weiner on 01-10-2003 at 06:33 (EST)
Based on your error message:

"Unable to open ../d:/home/Default/"

It sounds like you have the path to your listing directory incorrectly set to:


Instead of:


(Ie. There appears to be an extra "../" at the front of your path)

To correct the problem, just correct the corresponding configuration question:

If using uDirectory Deluxe, correct Configuration Question #4:
$html_directory = "d:/home/Default/";

If using uDirectory Personal, correct Configuration Question #2:
$relative_directory = "d:/home/Default/";

And that should do it for you!

© 2003 Microburst Technologies, Inc.