uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
CGI error in

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Mar-22-19 01:01 AM EST
Original Message
CGI error in
Author Andy Cunnah on 10-14-2000 at 05:49 (EST)
syntax error at line 615, near "sub validate_required_fields(" Execution of aborted due to compilation errors.

Any ideas?

This comes up when i try to view in the browser to login to the control panel.

I'm running the shop as a demo with a view to order the product.

I'm running on NT 4.0 IIS 4.0.


Table Of Contents
  RE: CGI error in Bill Weiner, 2000-10-14 14:29:49 (1)
            CGI error in Andy Cunnah, 2000-10-16 12:59:16 (2)
                 RE: CGI error in Bill Weiner, 2000-10-17 06:02:36 (3)
                      I've been there before Nick Kay, 2000-10-17 16:54:42 (4)

Messages In This Discussion
         1. RE: CGI error in
        Author Bill Weiner on 10-14-2000 at 14:29 (EST)
Based on that error, it sounds like the script may have gotten corrupted somehow. I would suggest just starting over with fresh "", "" and "" files straight out of the original zip file. Also, when transferring the scripts to your server, be sure to transfer them in ASCII or TEXT mode (as opposed to binary or raw transfer mode).

Also, if you've never installed Perl scripts on that server before, you may just want to verify that your server is configured properly to run Perl scripts by trying out the test script described at:
                 2. CGI error in
                Author Andy Cunnah on 10-16-2000 at 12:59 (EST)
Thanks, I've tried this but with no success.

It still says the same error message.

I have never been able to get this working since downloading. Its not as if has worked and then gone faulty.

The test script works fine.

I have even downloaded the files again.

Sorry to be a pain.

Any more suggestions?

If we can get this working it will be perfect for our needs.
                         3. RE: CGI error in
                        Author Bill Weiner on 10-17-2000 at 06:02 (EST)
As something else to check, I noticed from your paths that you are using an Windows server. Something that may be causing that sort of an error on a windows server may be the use of backward slashes ()in the configuration questions. That is, although backward slashes are OK to use on windows computers, such as:


Perl treats backward slashes as special escape characters.... so if you had something like this:

$data_directory = ".data";

That could result in that sort of an error.

As a rule of thumb, when specifying such directories/paths in the configuration questions of the Perl scripts, always use forward slashes (/)... as forward slashes will work on both UNIX and Windows machines, such as:

$data_directory = "./data/";

So double check that in the configuration questions of your "" script.... and if that doesn't solve the problem, send your "" file and your "" file to and I will take a look at them.
                                 4. I've been there before
                                Author Nick Kay on 10-17-2000 at 16:54 (EST)
Also "smells" like a recurrent problem I got. Eventually tracked it down to the FTP software...

1. When I uploaded the *.pl scripts they failed part way through.
2. When I ran them through the service provider's on-line script checker they passed!
3. When I downloaded them from the site back to my PC, they were OK

Therefore, I believed the problem was:
a. With the script
b. With the service provider

However, got the service provider to look at the script & was told it had "odd" characters in it.

Changed the FTP software - used to use Laplink-FTP, now use FTP-Surfer...

(touches wood) all problems have disappeared...

© 2003 Microburst Technologies, Inc.