uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
wizard doesn't help

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Aug-19-18 07:45 PM EST
Original Message
wizard doesn't help
Author Gerry Roe on 02-22-2000 at 14:17 (EST)
My host has a perl syntax analyzer, which gives me
the following results:

Name "main::uShop_total" used only once: possible typo at /u29/gruver/cgi-bin/ushop_cgiscript.cgi line 262.
Name "main::uShop_orderid" used only once: possible typo at /u29/gruver/cgi-bin/ushop_cgiscript.cgi line 261.
/u29/gruver/cgi-bin/ushop_cgiscript.cgi syntax OK

The host gives me the following information for using perl scripts:

Information commonly needed for perl scripts:

Path to perl: /usr/bin/perl
Version of perl: 5.004.04
Path to sendmail: /usr/lib/sendmail
Operating system: BSDi (older accounts), Linux (newer and some older
accounts) & AIX (Enterprise accounts only)

I guess I have an 'older' account, whatever they mean by that.

The paths are correctly set in the script, and a #! is used before the path to perl. The script was uploaded using ascii. The extention .pl was changed to .cgi, which is what the other scripts in my cgi-bin directory use. Permissions are set to read and execute for everybody. My email address uses a /@ in the script.

What else is there, and what might the 'typo' references mean? Thanks.

Table Of Contents
  cgi problems charlie edmunds, 2000-02-22 19:21:38 (1)
            wizard doesn't help Gerry Roe, 2000-02-23 00:28:23 (2)
                 cgi script charlie edmunds, 2000-02-23 20:33:25 (3)

Messages In This Discussion
         1. cgi problems
        Author charlie edmunds on 02-22-2000 at 19:21 (EST)

Have you tried to run the script? What happens?

When you uploaded the file, you did so in ASCII mode right?

Charlie Edmunds
Microburst Technologies, Inc.
                 2. wizard doesn't help
                Author Gerry Roe on 02-23-2000 at 00:28 (EST)
I've tried to run it by putting the path in the location window of the browser, and by sending the order form. In both cases I get an Internal Server Error. I did upload it in ASCII, using WS_FTP.

Could the misconfiguration result from contradictions in the script relating to storing the orders on my host, etc.? Or specifying the SMTP server although it's a UNIX host?
                         3. cgi script
                        Author charlie edmunds on 02-23-2000 at 20:33 (EST)

Can you email me a copy of your script and give me an url so I can take a look at it?

Charlie Edmunds

© 2003 Microburst Technologies, Inc.