uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Internal Server Error!

Knowledge Base Lobby : uReserve Support Conference : Troubleshooting Questions
Jul-20-18 06:47 AM EST
Original Message
Internal Server Error!
Author MikeR. on 06-29-2001 at 16:31 (EST)

I am trying to access which is installed on a Linux box running RedHat (I've tried it on 2 seperate systems, one running RedHat7.1 and the other RedHat6.1). I am using Apache-1.x for the webserver. When ever I try to access the script I receive the following error in my browser:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

In the Apache error log I find entries like the following:

[Fri Jun 29 17:09:06 2001] [error] [client] Premature end of script headers:/home/httpd/cgi-bin/ureserve.cgi

I get these same errors with both the script and the script. I use PERL regularly on this system and have no problem running other CGI script on it as well. The scripts are also perfectly it's not a matter of data corruption.

Any insight as to what is going wrong and how I might correct it would be greatly appreciated.




Table Of Contents
  RE: Internal Server Error! Bill Weiner, 2001-07-08 21:49:15 (1)

Messages In This Discussion
         1. RE: Internal Server Error!
        Author Bill Weiner on 07-08-2001 at 21:49 (EST)
There is definitely something wrong with the way the scripts are being installed on the server.

99% of the time, server errors with the scripts are caused by one of the three items listed in section 2 on the troubleshooting page:

So triple-check those items.

If that still doesn't resolve the problem, then some servers require that you run a dos2unix utility on the script. See if your server has that utility, and if so, try running it on the script.

© 2003 Microburst Technologies, Inc.