uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Problems with scripts loading

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Aug-16-18 06:44 AM EST
Original Message
Problems with scripts loading
Author Rhett Russell on 02-28-2000 at 19:19 (EST)
I am having problems getting my pages to load with the java scripts. I am getting numerous different error messages and different things are happening with some java applets.

When I try to load any of my catalog pages I get one of two dialog box error messages:

1: The server returned an unrecognized response
2: I/O error

I get these errors with IE 4 & 5 and Netscape.

I am also having problems loading the applet
uShopOrderDeluxeCGI.class It will load on the checkout page but not all the time. It give me a message that the appplet uShopOrderDeluxeCGI.class can't be found.

What's really strange is that I have been working fine for about 6 months, and then it all went to #$%^*@

Any suggestions?

You can view my site at:

The view cart page works very well but my catalog pages 1-5 seem to get stuck loading the java applets and the checkout page intermittently loads the uShopOrderDeluxeCGI.class applet

Help! I haven't had an order in close to 2 weeks. My ISP, Concentric Networks claims that this is a problem with the applets.


Table Of Contents
  Problems charlie edmunds, 2000-02-28 20:03:13 (1)
            getting closer Rhett Russell, 2000-02-28 21:50:30 (2)
                 Server Problems charlie edmunds, 2000-02-29 18:48:58 (3)

Messages In This Discussion
         1. Problems
        Author charlie edmunds on 02-28-2000 at 20:03 (EST)

I can imagine that your very frustrated. I did a couple of screen captures of the error messages. They looked like server problems to me. I'd try some plain pages (without the applets) and see if you still get error messages. I suspect that you will.

You might try downloading the latest version of uShop and replace your class files. Also carefully check your file permissions again. Make sure you upload the class files in the correct mode. You have all your class files located in the same place and reference them all the same way with the codebase parameter, right?

I'd check the basics first and verify that the stuff on your end is correct and then scream at your host support until somone will work with you.

Sorry I couldn't be more help,

Charlie Edmunds
                 2. getting closer
                Author Rhett Russell on 02-28-2000 at 21:50 (EST)
Thanks for the ideas. I have loaded the latest versions of Ushop into my /classes folder and I checked out the permissions -- they are OK too.

I use WS_FTP to get the files to the server, so I know that I have transferred everything OK. Besides, I didn't change anything. I wonder if my ISP may have done something that could change the format of the files? I'll check this out too.

I haven't changed the codebase parameter. It still references all of the files for each of the applets in the same place. That's the first thing that I checked.

I have all of the files in the correct spots. I was wondering if I put the java class files in the same folder as my web pages, would this cause any problems? This is something that I do with .dll files with VB to make sure that I reference the files I want. Or am I making this too complicated?

I just tried to access my site and I can finally get into the darned thing. So I don't know if it was that new scripts or the ISP finally doing something about it.

I really appreciate your fast response on this.

P.S. I love the software, just don't like the problems with my ISP. Can you e-mail me privately and give me any assistance on finding a new ISP who you know works well with your software?
                         3. Server Problems
                        Author charlie edmunds on 02-29-2000 at 18:48 (EST)

I checked your site and was able to place an order and get a receipt. I did notice on the second page that there was an input applet that didn't load. It appeared that the class file was not on the server. It looks like you're close now to having it working again.

Charlie Edmunds
Microburst Technologies, Inc.

© 2003 Microburst Technologies, Inc.