uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Continue button disappeared

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Jul-16-18 08:43 AM EST
Original Message
Continue button disappeared
Author Jeff Lighthall on 11-28-2001 at 16:15 (EST)

When going through the order process everything works fine until the order form. There is a button at the bottom with no wording. It used to say continue, but now nothing. Has anyone run into this problem?

Table Of Contents
  uShop footer tag error Microburst Support, 2001-11-28 23:07:53 (1)
            RE: uShop footer tag error Bill Weiner, 2001-11-29 23:46:34 (2)
                 It worked ;-) Jeff Lighthall, 2001-12-04 10:48:40 (3)

Messages In This Discussion
         1. uShop footer tag error
        Author Microburst Support on 11-28-2001 at 23:07 (EST)
if you check your uShop footer tag in the uShop Order Template File

you will see that you have :

INPUT TYPE="submit" VALUE=""
it should be:
INPUT TYPE="submit" VALUE=" Continue "

simply put the word Continue back and that should do it
                 2. RE: uShop footer tag error
                Author Bill Weiner on 11-29-2001 at 23:46 (EST)

Actually, it sounds like you are running into the problem discussed on this support forum posting:

That is, try logging in to the uShop Control Panel and press the "Diagnostic" button. In the Diagnostic Report that is generated, notice under GENERAL SETTINGS whether the following values are blank:

$settings[28] = Continue
$settings[57] = Continue
$settings[60] = Continue
$settings[170] = Continue

My guess is that instead of saying "Continue", those settings are blank:

$settings[28] =
$settings[57] =
$settings[60] =
$settings[170] =

This most likely occurred due to a directory permissions problem that existed at the time you first installed the uShop scripts and first tried logging in to the uShop Control Panel. A permissions problem may have prevented those values from being properly set.

To correct the problem, there are two things you can do:

OPTION 1: FTP to your server and look in your uShop's "data" directory. Delete the "ushop-settings.txt" file. And then re-login to your uShop Control Panel and reconfigure your General Settings. (Basically starting over and re-doing your uShop General Settings).

OPTION 2: Or if you don't want to re-do all of your uShop General Settings, then you can manually try inserting the missing fields into the "ushop-settings.txt" file. To do that:

STEP 1: Use your FTP program to transfer the "ushop-settings.txt" file from your server's cgi-bin/data directory - back to your local computer. When transferring this file BE SURE TO TRANSFER IT IN ASCII TRANSFER MODE!

STEP 2: Make a backup copy of your "ushop-settings.txt" file... just in case.

STEP 3: Use any text editor (such a WordPad) to open the "ushop-settings.txt" file.

STEP 4: Make the continue button label changes on the following lines:


The default values of these lines (originally written based on your file) should be:


...for lines 29, 58, 61 and 171, respectively.

STEP 5: Save the changes (as TEXT if your editor asks).

STEP 6: Re-transfer the file to your cgi-bin/data directory... AGAIN, BE SURE TO TRANSFER THE FILE IN ASCII TRANSFER MODE.

STEP 7: Try it out!
                         3. It worked ;-)
                        Author Jeff Lighthall on 12-04-2001 at 10:48 (EST)
It worked Thank you very much! The only thing is my file only goes up to line
$settings[164] .


© 2003 Microburst Technologies, Inc.