uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
applet 20

Knowledge Base Lobby : uShop Support Conference : General Questions
Aug-18-18 08:28 PM EST
Original Message
applet 20
Author the shadow on 04-26-2001 at 22:09 (EST)
I am using the applet 20 and have a question about the view button. I am trying to target a frame to display an html page. It's targeting the entire window. I call the frame main, and the frontpage 2000 program that I am using is not using a base target tag. I am putting the target parameter in the applet and putting main as the value.

Can you help me with this problem?


Table Of Contents
  RE: applet 20 Bill Weiner, 2001-04-26 22:14:57 (1)
            Still nothing the shadow, 2001-04-30 19:24:55 (2)
                 RE: Still nothing Bill Weiner, 2001-04-30 21:54:54 (3)
                      I've removed the tags the shadow, 2001-05-01 04:09:06 (4)
                           RE: I've removed the tags Bill Weiner, 2001-05-01 20:32:54 (5)
                                Thanx the shadow, 2001-05-02 03:38:38 (6)
                                Downloaded.... the shadow, 2001-05-03 17:51:09 (7)
                                     RE: Downloaded.... Bill Weiner, 2001-05-03 21:46:37 (8)
                                          Feeling simple the shadow, 2001-05-04 03:56:56 (9)
                                               RE: Feeling simple Bill Weiner, 2001-05-06 21:43:34 (10)

Messages In This Discussion
         1. RE: applet 20
        Author Bill Weiner on 04-26-2001 at 22:14 (EST)
If the frame that you want to target is called "MAIN"... then make sure that the applet's "target" parameter is set to:

< PARAM NAME="target" VALUE="MAIN" >

Otherwise, give me the URL and I will take a look at it.
                 2. Still nothing
                Author the shadow on 04-30-2001 at 19:24 (EST)
I have it set the way you are suggesting, but still no go. The frame is called main, all small caps. The site isn't fully built yet, but this will get you past the front page.

(ushop 3.3)
                         3. RE: Still nothing
                        Author Bill Weiner on 04-30-2001 at 21:54 (EST)
I took a look at your site... and it appears that you have the target parameter set correctly to "main". So I'm not totally sure why it is not working for you.

As a test, I just modified a copy of the uShop Applet Reference that is included with uShop and set the TARGET parameter of the uShopInput20 applet to "FRAME2"... and that succussfully kept the "VIEW" links within "FRAME2"... so it definitely works. I just can't spot what the problem is on your site.

Perhaps it has something to do with how you setup your frameset on your "sindex.html" page. Or maybe it has something to do with the < base target="_self" > tags that you put on the pages. I would suggest trying the test that I performed above... just to see how it should work...and perhaps while doing that, you will discover what is different your site.
                                 4. I've removed the tags
                                Author the shadow on 05-01-2001 at 04:09 (EST)
I've removed the base target tags and the one in the frameset, but still no go. I even renamed the main to FRAME2, and back to main, but applet 20 is still not directing the view link into the frame.

Any other ideas on what I could have missed?

                                         5. RE: I've removed the tags
                                        Author Bill Weiner on 05-01-2001 at 20:32 (EST)
Well, I copied your sindex.htm, contents.htm, main.htm, and f111.htm pages onto my local computer and tried out the "View" button locally.... and it worked fine. So that means that you must have an old version of the uShopInput20 .class file on your server. Make sure you have the class files from version 3.15 (or later) on your server. Re-download them if necessary.
                                                 6. Thanx
                                                Author the shadow on 05-02-2001 at 03:38 (EST)
Thanks for the input. I'll download them again.

                                                 7. Downloaded....
                                                Author the shadow on 05-03-2001 at 17:51 (EST)
I've downloaded and reinstalled the 3.4 version and the applets, but when I view the uploaded site, the applets are the same on my development computer.

I figured this a cache problem, so I emptied all that I could from my IE 5.5 tools/options, but they remain.

Interestingly enough, when I erase the entire classes directory from my server, and view it, all applets are still working as if they were never removed.

I thought I was losing it so I shut off my computer and went to sleep. The next day my site runs with no applets on it!

What's going on?!?
                                                         8. RE: Downloaded....
                                                        Author Bill Weiner on 05-03-2001 at 21:46 (EST)
The applets will not run without any lass files, so it sounds like:

1) You didn't install/delete the class files from where you think you did.


2) The class files are still in your browser's cache... in which case, you need to clear your browsers cache.

As for the target still not working, I would suggest trying the test that I tried. After downloading a fresh copy of uShop, go right into the "reference" directory and add the target = "FRAME2" parameter to the uShopInput20 reference page. After going through that exercise, you may be able to more easily spot the problem with your store's HTML pages.
                                                                 9. Feeling simple
                                                                Author the shadow on 05-04-2001 at 03:56 (EST)
I have to admit, I've spent the last few hours trying to figure out where I've gone wrong on this,

This is the process I've gone through to view the new 3.4 applets after the 3.3 ones have been removed from my server, and have been replaced by the 3.4 ones.

1. I've removed the class files from my server. Having done this, they shouldn't show up in my browser right? I go to my website, view the site and they show up.

2. I go to a friends house and check it in his browser, and it doesn't show up. (As they shouldn't)

3. I return to my computer and the applets show up. The path to the class files only point to their location on the server. I double check this.

4. I take a swig of Jack Daniels.

5. Figuring it is in my internet explorer browser cache, I go up to Tools, and Internet options.

- I delete files, including all offline content.
- I view files, they aren't there.
- I clear history.

6. I go to my internet explorer, refresh. The Applets still appear.

7. I pour myself a double.

8. I go to the location on my hard drive using windows explorer, and they have been removed.

I look in my browser they are still there.

9. Another double.

10. I shut off the computer, turn it on, go through step 5,6 and 7 again. Still, applets are there.

11. I replace the ones on the server with the 3.4's again. Run it, it is still the 3.3's. I erase the ones on the server.

12. I erase the ones on my hard drive. They no longer exist anywhere on my computer, or my server.

13. They still show up in my browser. I phone several friends, they don't see the applets. They think I'm drunk. I tell them I am. The html documents point the codebase directly into the classes directory on my server. (An empty directory)

13. I am stuck at step 9. I have run out of Jack, and the ability to think through this. Any ideas, and especially solutions would be very very apreciated.

p.s. the 3.4 files work when I run them on my development computer. (I'm referring to the original frame target paramater that finds the 'main' frame as was originally intended. The problem is when I upload to the server to run 3.4, but the 3.3 ones still seem to be running the show.)

Thanks, G'night.

                                                                         10. RE: Feeling simple
                                                                        Author Bill Weiner on 05-06-2001 at 21:43 (EST)

It sounds like the class files are still cached in your browser somehow. Here are a few suggestions for clearing your cache:

1) If using the latest version of IE, I believe there is a separate Java option on the "Start" menu by which you can chose whether or not to cache class files or not. So maybe check there.


2) You may be able to force your browser to try to reload the class files by temporarily changing the codebase of just one of the applets on your HTML pages. Try changing it to anything.... and then after you see the "class not found" .. change it back.

© 2003 Microburst Technologies, Inc.