uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Internal Server Error...

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Jul-15-18 08:29 PM EST
Original Message
Internal Server Error...
Author kachurak on 08-26-2000 at 00:27 (EST)'s the deal. I am hosted on a UNIX box with *.cgi capabilities in ALL directories, subs too. I have and am still running the UShop 2.0v on my server. I have tested and tried to complete the following:

First, upload (ASCII) the file to a directory (attempted 5 different directories with the same result in each). I then performed CHMOD to 755 on the file, and renamed it to cgi extension. I tried different R/W/X commands, tried *.pl and *.cgi with this file to no avail. In addition to this, just to make sure I could "read" the script, I left it in the *.pl extension and could view it FINE with NS 4.0, 4.74, 4.75 and 6.0 as well as IE5.0 and 5.5.

Second, I uploaded the file (ASCII) ...changed to 755 and renamed the extension to *cgi. NO PROBLEM!! I've done it before and tried the SAME 5 directories that the file was loaded to. I ALSO, just for trial, tried changing and making sure the directory to the orders/data directory was correct, I used the FULL URL and the ./data/ and ./orders/ (ushop v2.0) and STILL the same problem.

I compared the differences between the files, v2.0 and v3.0 and the ONLY thing that I can arrive at that MAY be causing the problem is the fact that I don't have a secure server?! However, in your notes on the setup, it says that if you DON'T have a secure server, your public one may be used until that time. That's what I put in, so what could I be overlooking?? Anyone??

The ONLY reason that I got v3.0 is because of the interface. But if I can't get the v3.0 script to load, then what good is it?

Matt Kachurak


Table Of Contents
  RE: Internal Server Error... Bill Weiner, 2000-08-26 09:50:05 (1)
            ABSOLUTELY!! kachurak, 2000-08-26 11:08:41 (2)
                 RE: ABSOLUTELY!! Bill Weiner, 2000-08-26 14:41:10 (3)
                      Will do! kachurak, 2000-08-26 16:38:32 (4)
                      GUESS WHAT!! I found the fault! kachurak, 2000-08-26 16:58:09 (5)
                           WOW>...!!! kachurak, 2000-08-26 17:10:44 (6)
                                RE: WOW>...!!! Bill Weiner, 2000-08-28 06:12:03 (7)

Messages In This Discussion
         1. RE: Internal Server Error...
        Author Bill Weiner on 08-26-2000 at 09:50 (EST)
So just to make sure I understand the situation:

1) You currently have the uShop 2.x script running successfully on your server.

2) You currently have the script running successfully on your server.

3) But, now, when just trying to go to the URL of the uShop 3.0 script, you are getting a "Server Error".

4) In an attempt to correct that "Server Error", you have already tried the suggestions listed at:

Q1) So are all of the above correct? Especially the time at which you are getting the "Server Error"...when just trying to go to the URL of the script?

Q2) Are there any additional text/error messages being displayed with your "Server Error"? Such as "Unable to locate"?

Q3) Also, since you mentioned that you renamed the script to ushop.cgi (with the .cgi extension), did you remember to rename the ushop-lib and ushop-languages files too? And did you also remember to make the corresponding ".cgi" changes to configuration questions #11 and #12 in the ushop.cgi script?
                 2. ABSOLUTELY!!
                Author kachurak on 08-26-2000 at 11:08 (EST)
Bill.. just wanted to touch up.. first, I commend you (UBurst) on your support, I thought for SURE that I wouldn't hear ANYTHING until Monday next week!.. HOORAY~!

Q1 = Yes
Q2 = No, no other message or information
Q3 = Yes, I tried that too but to no avail. It was getting rather late when I did this, so I'll definitely try that again, but I'm 99.99% positive that I tried it with every configuration that I tried.

Other than that, any more ideas?

I'm still a little baffled myself!

Take Care,
                         3. RE: ABSOLUTELY!!
                        Author Bill Weiner on 08-26-2000 at 14:41 (EST)
Well, because the error is occurring just when going to the URL of the script, that eliminates the possibility of the problem being related to the "data" (or "orders") directory/path nor the email configuration.

And the fact that you have other scripts in that same directory running, eliminates the possibility of the directory not being configured to execute scripts.

And you've already double-checked the perl path, permissions and ascii transfer mode.....

.... So that really covers most possiblities.

All I can really suggest (after you check those ".cgi" settings described in the previous post), is to go ahead and send us the settings located at the top of your uShop 2.x script and your uShop 3.x script and I take a look at them. Maybe I will be able to notice what could be causing the problem.

Just send them to ... Although that WILL have to wait until Monday since I can only check that email from our office. :^)

                                 4. Will do!
                                Author kachurak on 08-26-2000 at 16:38 (EST)
Thanks again Bill for replying so fast. I will make sure that I include the comparison, you are talking of the "questions section" right? That's what I'll forward to you.

Maybe you can see the difference, but I will most certainly try to do it again, from scratch, just in case I am overlooking something!

Talk to you soon!

Matt Kachurak
                                 5. GUESS WHAT!! I found the fault!
                                Author kachurak on 08-26-2000 at 16:58 (EST)
Hey Bill...

After reading and trying to figure out exactly what the problem is, I was reading down through the instructions and had some problems with figuring out why, I found the answer!

The answer: ALL THREE scripts,, and files needed to be loaded to the directory! I went back through the instructions one more time and couldn't find any reference to uploading all these files to the same directory in the instructions. The only mention that I found is the following: "Once the uShop scripts have been configured as described in the previous sections, (10.6) you can now transfer the scripts to your server."

So what it boiled down to was a miscommunication on both parts, the instructions and MY misunderstanding them, thinking that they meant the script ALONE!, whew...I was losing it, better get more sleep next time before trying to configure that again!

So, needless to say, they work just fine, I'm sure that if I was to misread them, others might also. UBurst may want to consider adding a quick note to section 10.6 and say that all three scripts, "naming them" should solve the problem. I am a very technical person and work for an ISP as dial up support services, so I know pretty what I'm doing.

Thanks again for the help, all is well! If you want to see, check out:

Take care!

Matt Kachurak
A+++ service from you guys all the way!
                                         6. WOW>...!!!
                                        Author kachurak on 08-26-2000 at 17:10 (EST)
What an incredible interface that control panel is!! I will DEFINITELY reccomend UShop to EVERY customer of mine. I do site design and hosting on the #2 virtual hosting company on the net!

Great Job and I am ecstatic that I spent the money on upgrading from v2.0!

Any chance on UShop getting an affiliate program started!?? ;)

                                                 7. RE: WOW>...!!!
                                                Author Bill Weiner on 08-28-2000 at 06:12 (EST)
Thanks for the nice complements....

...and thanks for the feedback on that "Server Error" problem. We'll be sure to make the documentation clear for others running into the same problem.

As for an affiliate program, I believe our sales folks have been considering it, but for now, we only have a "reseller program" described at:

© 2003 Microburst Technologies, Inc.