URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_applets_shopcart
Thread Number: 70
[ Go back to previous page ]

Original Message
"All greyed out!!"

Posted by Peter [mydreaming@dingoblue.net.au] on at 11:58 AM
I'm getting the sack in 5 hours if I don't get it working!!!! uShop Lite -downloaded july.
"Error codebase class file not found"
All the applets work fine on local machine.
Duplicate this on the server and nothing shows.
Site is http://www.body-electronics.com
click on the red order button and the popup comes up with the frames and html working fine.
Just no app's showing. All class files are loaded into the body-electronics.com/shop/ directory, same as the html files.
No codebase used locally, works fine. On the sever no go. Also tried using the full URL in the code base,
codebase="http://www.body-electronics.com/shop/" no go, locally or live. Tried all sorts of solutions, no go.
Do capital letters matter, it's on a Unix server?
Yes I've gone grey overnight.
BTW we purchased V.3 at the same time but it's meant for a different site, the boss is dark because this purchase was made on my rec.
"If you can't make the lite version work, what sense is there in installing the retail version?"

Table of contents

Messages in this discussion
"RE: All greyed out!!"
Posted by Bill Weiner on at 12:38 PM
I took a look at your site at:


And immediately saw in the Java Console the following error:

# Applet exception: class uShopCart could not be loaded

So then I tried going to the following URL to see if the uShopCart.class file is indeed on your server:


This URL resulted in a "File Not Found" error.

So, since you mentioned something about capital letters, it tried going to the following URL:


And sure enough, the file "ushopcart.class" files is there...so THERE’S YOUR PROBLEM!


You must have the .class files names match the original names of the files as listed on the applet references ... all the way down to the capital "S" in uShop ... and the capital "C" in Cart.