URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_applets_shopcart
Thread Number: 62
[ Go back to previous page ]

Original Message
"Search & Browse applets are not working!"

Posted by Citra Store Sdn Bhd [citras@po.jaring.my] on at 04:46 AM
Dear sir,
I've this damn problem. I just bought the program and i'm using it.But i'm really frustrated to find out that the browse & serach applets are not working! Can anybody tell me the real reason?

Table of contents

Messages in this discussion
"RE: Search & Browse applets are not working!"
Posted by Bill Weiner on at 02:17 PM
Have you tried the Search/Browse applets straight out of the applet reference that was installed on your local computers when you unzipped/installed uShop 3.0? And if so, did they work when ran off of your local desktop computer?

If they didn't work for you as-is, then are you seeing any error messages in your browser's status bar and/or Java console? That is, you may be running into a problem that we have had a few other reports about. Apparently some people when trying to run those applets off of their local desktop computer get some "security exception" error. We think this may be related to the browsers search paths on your local desktop computer but are still looking into it. In any case, those Seach/Browse applet should run fine for you as soon as you put them on your server and try them out from there.

Otherwise, if the Search/Browse applets did work as-is from your local desktop computer...but are not working in the new pages that you are developing, I'll need more information about your directory structure and HTML. Give me a test URL where I can take a look at it ... or submit a support request the info/html and we will take a look at it.

"Thank you!"
Posted by Citra Store Sdn Bhd [citras@po.jaring.my] on at 06:33 AM
Dear sir,
Thank you. I managed to fix the problem. All i had to do was to upload it to the server with all the .class files. The only problem i've now is that the cgi script is not working properly. Just try sending a order through this site: www.citrastre.com.my/onlinestore/checkout.html
the languages cgi is not found although i've uploaded it and also tried changing it to D:/... as stated in the reference.