URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_applets_shopcart
Thread Number: 57
[ Go back to previous page ]

Original Message
"No Applets are showing"

Posted by jalina [jalina_M@hotmail.com] on at 09:41 AM
I have been racking my brain for days now trying to find what is wrong. This is the error msg I have been getting
Applet uShopCart error:java.lang.NoClassDefFoundError

It was all working fine before and now suddenly none of them are working

Here is the addy if you want to take a look.

Thank you for your time

Table of contents

Messages in this discussion
"RE: No Applets are showing"
Posted by Bill Weiner on at 10:55 AM
I took a look at your uShop 2.x site and noticed the following errors in the Java Console:

java.lang.NoClassDefFoundError: uShopCartBase
java.lang.ClassNotFoundException: uShopProducts
java.lang.ClassNotFoundException: uShopLibrary

....which is a good indication that you don't have all of the "required" uShop class files on your server.

So then I took a look at your classed directory at:


And can indeed see that the following required class files are missing:


So try transferring those class files to your server and that should correct the problem.

Note that you can see a listing of all required class files in the "Required Applets" section of the uShop 2.x applet reference:


"No Applets are showing"
Posted by jalina on at 12:22 PM
Thank you for answering so quickly.
I have added the files that you listed that were missing. Unfortunatly it is still not working for me.
They at one time were working and then for some reason unknown to me they stopped. I am truely getting frustrated with this. Could you please take another look at it for me, I would greatly appreciate it.

Thank you for your time.

"RE: No Applets are showing"
Posted by Bill Weiner on at 01:59 PM
I took another look at your site and can now see the following error message being displayed in the Java Console:

"java.lang.NoSuchMethodError: uShopProducts: method checkTrialVersion ()Z not found"

...this error message is a good indication that you have some of the uShop 2.x trial version class files and some of the uShop 2.x full version class files on your server. It is extremely important not to mix the class files of the trial version and the full version.

To correct it, I would suggest deleting ALL of the class files from your server...and then re-transfer all of new class files to your server.

"No Applets are showing"
Posted by jalina on at 05:36 PM
Okay that fixed it and I feel like a bit of a dolt but at least its working now :)
Thank you so much for your time and help. With my knowledge of this stuff I am sure we will be talking again soon :)

Thank you again