URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_applets_shopcart
Thread Number: 52
[ Go back to previous page ]

Original Message
"Text file applet"

Posted by Peter G [peter@topcom.nu] on at 10:26 AM
In uShop3, trial version, the applets that read data from a text file dont show. In the status bar it says something about "Security.exception", whats wrong??

Table of contents

Messages in this discussion
"Text file applet"
Posted by Charlie Edmunds [cedmunds@uburst.com] on at 05:40 PM

Can you give me the exact error message? You may want to check out our reference site. There is some good information there for troubleshooting.


Thanks, Charlie Edmunds

"Error message!"
Posted by Peter G [peter@topcom.nu] on at 07:30 AM
The error message reads:

"exception: com.ms.security.SecurityExceptionEx(uShopLibrary.readFile): java.io.IOException: bad path: C:\WINDOWS\Desktop\uShop"

"RE: Error message!"
Posted by Bill Weiner on at 09:58 AM
Make sure you have a "classes" directory setup as described in section 5 of the uShop 3.0 User's Guide:


And that your data files are located in your "classes" directory.

Posted by Peter G [peter@topcom.nu] on at 01:45 PM
I have a classes directory and the applets are in the right dir.! I downloaded the trial-version and unzipped it, Ive made no changes, still it wont work!?!?

"RE: Classes"
Posted by Bill Weiner on at 02:46 PM
1) When you unzipped/installed uShop 3.0 on your local desktop computer, was the directory structure shown in Figure 1 at:


created on your local desktop computer?

2) And if so, were you successfully able to open the "index.html" file with your browser and link to the uShop 3.0 Applet Reference on your local desktop computer?

3) And if so, were the Search/Browse applets working for you from that installed uShop 3.0 Applet Reference?

4) And if not, do the Search/Browse applets on our online uShop 3.0 Applet Reference:


work for you?

5) And finally, what type of browser and operating system are you using?

"Still not working"
Posted by Peter G [peter@topcom.nu] on at 04:45 PM
1) Yes
2) Yes
3) No
4) Yes they do
5) Im using Windows 98 an Microsoft Internet Explorer 5(swedish version)

Also, the last part of the error message reads "/uSho", not "/uShop" as I wrote. My mistake! Ive tried downloading the trial version several times but it is still not working!!??

"RE: Still not working"
Posted by Bill Weiner on at 05:43 PM
We've had a couple other people mention that the search/browse applets weren't working when viewing those particular applets on their local desktop computer, but that they do work fine when viewing them from their server. My guess is that it has to do with the search path of the browser when viewing the HTML files from their local desktop computer. We'll look into it a little more, but the important thing is that those 4 applets work fine when loaded from the website.