URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_applets_shopcart
Thread Number: 51
[ Go back to previous page ]

Original Message
"Some Users Still Cannot See Applets"

Posted by Brian Levine [blevine@cfl.rr.com] on at 02:40 PM
I have my site set up with uShop 2.0, while most users can use it fine, I still get a fair amount of complaints from people claiming they cannot see the prices/descriptions. A user who has verified that they have Java enabled sent me this message:

Java is definitely enabled in my browser (IE5) yet the price/add button do
not show up. When I move my mouse over one of them, I get the following
message in the status bar: "load: class uShopInputVertical not found".

My site is at www.animecollectibles.com. Frankly, I have held off on registering uShop until I get this issue resolved, as it affects about 20% of my users.

Any help is appreciated.

Brian Levine

Table of contents

Messages in this discussion
"Class directory"
Posted by Pop on at 03:46 PM
Do you have your class files placed in the correct directory? That would be "../classes" (I had a look at your site)

"Class Directory Looks Fine"
Posted by Brian Levine [blevine@cfl.rr.com] on at 04:01 PM
Yes, they are all in the class directory.

It seems to me that if this were wrong, no one would see the classes. For about 80% of my users, everything works fine. One user reported the class not found error. Would I be better off putting the classes in the root directory?

"class files"
Posted by Charlie Edmunds [cedmunds@uburst.com] on at 07:50 PM

How you handle your class files can definately cause the problem that you are describing (especially considering the error message that your customer saw).

check out this information on handling your class files:


If you still have trouble, I'll take a look at your site.

Thanks, Charlie Edmunds

"RE: class files"
Posted by Bill Weiner on at 10:01 AM

And also be particularly carefull that your codebase setting is EXACTLY the same for ALL of your applets.

"It Worked!"
Posted by Brian Levine [blevine@cfl.rr.com] on at 07:46 AM
Okay, this worked. I replaced all of the "..\classes\" with the full path in the CODEBASE statement, and now everyone seems to be okay.

Seeing as I had problems with both users of Netscape and IE (I got a lot of complaints about people not being able to see the applets running), you might want to document this solution.


"I had the same problem at first"
Posted by Paul Abernathy [Info@radiopet.com] on at 12:44 PM

Glad to see you got it solved, I also changed my CODEBASE to a direct path because it seemed to help those with older browsers load faster and better and even help on some that would not load at all....If you look at my site all my applets have the direct path for the CODEBASE.

Paul W. Abernathy