URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushp_general_purpose
Thread Number: 417
[ Go back to previous page ]

Original Message
"Orders will not delete from control panel"

Posted by Clint [root@33king.com] on at 11:52 AM
Message that order has been deleted appears... but the order is still there.

Table of contents

Messages in this discussion
"RE: Orders will not delete from control panel"
Posted by Bill Weiner on at 06:19 AM
Question 1) So after selecting the order file from the uShop Order Reader, choosing "Delete", and confirming the deletion, the Order Reader panel displays the message "The file was deleted"? But no error messages?

Question 2) If you FTP to your server and look in your uShop "data" directory, do you see the order file still there? (The order file name would be in the format ORDERNUMBER.order - where ORDERNUMBER is the actual order number.) Do still actually see the ".order" file that you attempted to delete from the Order Reader panel?

Question 3) What type of server are you using: Unix-type or Windows-type?

"Same problem"
Posted by Eric J. White [ejwhite@vrinnovations.com] on at 06:17 PM
I have also noticed this order problem. Says it was deleted but it's not there.
I also had a problem a while ago when I edited the Log, it wiped out all my affiliate credits.
Now, people with "medium" set on IE do not set cookies.
Seems there is a serious problem. I'm running 3.4 on the theory of "if it ain't broke don't fix it."
Should I upgrade?
(I'm getting 1.7 million hits per week, and can't afford to braeak the server or have down time.)

"RE: Same problem"
Posted by Bill Weiner on at 06:48 AM
I'm not quite sure of the problem you are describing. It sounds like the ability to delete orders is working fine for you??? (ie. "Says it was deleted but it's not there")??? Please elaborate.

PS. In regard to cookies, uShop does not require cookies.... it helps if you are using the "affiliate tracking" feature, but it not required.

"Broken Affiliate tracking"
Posted by Eric J. White [ejwhite@vrinnovations.com] on at 11:04 AM
All along I thought that cookies were the problem.
I have little or no affiliate tracking. Something is broken. I recently had an affiliate testing the setup, and her sales didn't track. And yet, when I do it, it works OK. The only difference that I could come up with is she has Medium security that blocks cookie (and the report said she did block third party cookies) and I have my browser security set to low.
But I'm not getting alot of affiliate tagged orders, and as I said, One time I tried to edit the log, and it deleted all the current affiliate account amounts.

I'm also getting a continuing error in my server logs about:uShopCart2.class
Which I use in the shared border of all my pages. This may be a configuration error on my part, or part of the Microsoft Java Thing.
Again, I am using 3.40 and was afraid to touch it for fear of crashing it.
I can get you access to the server to see the error I speak of, but would prefer to not list it here for obvious reasons. You should have my password to my store in your files, or I can provide it.
(I'm still a mostly happy Ushop customer, lest anyone get the wrong impression)

Posted by Eric J. White [ejwhite@vrinnovations.com] on at 11:06 AM
Oh, and sorry, I mispoke.
When I try to delete, it says deleted, but the transaction is still there.
(I created a page for affiliates to test their setup, and need to delet those orders afterwards. they just don't go away, but it says "successfully deleted")

"Still waiting"
Posted by Eric J. White [ejwhite@vrinnovations.com] on at 01:00 PM
I'm still patiently waiting for a reply to my problems.

"Orders do not delete"
Posted by Microburst Support Team [support@uburst.com] on at 01:20 PM
We were under the impression that the forum posting by "Rocky" was yours due to the very similar wording - so our answer had been posted there several days ago. Here is the link to that posting


...which we answered:

You might be looking in the wrong data directory when you check to see if your files are actually gone...but if you sure that you are looking in the right place, see if that data directory has full permissions on that Windows server. Can you delete the files manually through an FTP program? Were the files somehow changed to read-only?
If still no luck troubleshooting this on your own, please reference the new support policy effective Aug 1, 2003: http://www.uburst.com/support.html

Upon compliance with this new policy, we can FTP to your server and try to troubleshoot that way.