URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum:
Thread Number: 19
[ Go back to previous page ]

Original Message
"Failed to create new database for editing"

Posted by Michael [mfunk@qni.biz] on at 10:39 AM
I keep getting this message when trying to add/remove/modify users. Things worked fine up till yesterday, then this.

It's on a Red Hat 8.0 box running:
httpd-2.0.40.11 (Apache 2.0.xxx)
perl-5.8.0-55

File per's for both CSV's are 644 user apache:apache and placed in a dir with 777 user root:root

CGI is in the default CGI-BIN with 777 user root:root

This box basically supports this application and MRTG. It isn't internet accessible.

What's changed? (Did an auto-update sneak something in on me that made it fail? I think I have auto-update turned off!!?!)


Table of contents

Messages in this discussion
"I fixed it on my own"
Posted by Michael [mfunk@qni.biz] on at 02:56 PM
It appears that the update to Apache/2.0.40 (Red Hat Linux)makes the cgi unable to create the temp files that is uses(*.cbk)in the cgi-bin directory. The default cgi-bin directory permissions are 755 root:root.

To get things running, you can either set the perm's on the cgi-bin directory to 755 apache:apache or modify the directory options in the httpd.conf file for the cgi-bin alias. Either way, mine works now.

My only request out of this whole thing is for Microburst to spend some time on the documentation. It's a bit sparse!