URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_cgi
Thread Number: 179
[ Go back to previous page ]

Original Message
"No SMTP address specified"

Posted by Mark Weber [webmaster@coastalpet.com] on at 03:43 PM
At the end of the order process when a user clicks the send button a message appears stating: "Configuration Error" No SMTP address specified. I just started having this problem. Everything used to work fine. Not sure if something on the our server has changed. Need some help on what I need to do to correct this problem. Thank You so Much!!!!

Table of contents

Messages in this discussion
"RE: No SMTP address specified"
Posted by Bill Weiner on at 05:01 AM
If you weren't having that problem before... then yes, something on your server definitely changed.

Since the problem sounds to be e-mail related, I would suggest first logging in to the uShop Control Panel and pressing the "Diagnostics" button. From the "Diagnostic" screen, press the "Email Test" button (located at the bottom)... and see if that gives you any more insight into the problem.

I would then suggest checking your email settings in configuration question 7 - 10 of the ushop.pl script and see if those settings need to be updated due to the server configuration change.

"No SMTP address specified"
Posted by Mark Weber [webmaster@coastalpet.com] on at 07:47 AM

I tried using the Email Test from the Diagnostic screen and I get the same result. I get a screen that says "No SMTP address specified." The settings in the ushop.pl have not changed. The mail settings on the server are as follows:

Incoming POP3 Server- mail.safaripet.net
Outgoing (SMTP) Server- mail.safaripet.net

It is a Windows based server and I'm guessing by the above information that it does include a SMTP server. I'm using the "Sockets" set up in the ushop.pl script and that has worked fine up until a few days ago. Any clues on how I can get this back in working order again. Please help!! Thank you so much. I have had a few questions in the past with Ushop and your support has been amazing. Thank You!!


"RE: No SMTP address specified"
Posted by Bill Weiner on at 05:00 AM
And so you have configuration question #10 at the top of the ushop.pl script currently set to the following value?

$smtp_address = "mail.safaripet.net";

Maybe try specifying that setting as the actual IP address of your mail server... Or vice-versa, if using the IP address in that setting now, then try using "mail.safaripet.net" instead.