URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: uReserve_troubleshooting
Thread Number: 15
[ Go back to previous page ]

Original Message
"Illegal referer"

Posted by David Schrimpf [david_schrimpf@link.freedom.com] on at 10:19 AM
I have a client using the ureserve 1.01 script that I set up. They have been using it for a few months with no problems but today they started getting this illegal referer error.

They click on the name of the resource to bring up the small window. They fill in the appropriate information and click the "Reserve" button. That is when the error appears.

I just noticed that when you click on the name of the procedure on a certain day, it adds "#DAY2" to the URL. Could that be causing the illegal referer?

For what it's worth, it works perfectly from my location every time, but hasn't worked for them at all today.

Thanks in advance for any help

Table of contents

Messages in this discussion
"Re: Illegal referer"
Posted by Joseph Pishgar [support@uburst.com] on at 12:33 PM
Hello David,

Could you provide us with a URL to check the site out at?

Sounds like something browser-related.

Joseph Pishgar

""Re: Illegal referer""
Posted by David Schrimpf [david_schrimpf@link.freedom.com] on at 01:35 PM
I emailed support@uburst.com with the URL. I didn't want to post it in a public place.

Thanks for checking it out.

If it helps, I have tried it with the following browsers:

IE5 / Mac
Netscape 4.77 Mac

IE 5.5 (AOL version) on Windows 98

and had no problems. I haven't been able to duplicate the problem from my two locations, but they have duplicated it from two different locations.


"Re: Illegal referer"
Posted by Joseph Pishgar [support@uburst.com] on at 02:47 PM
Thats odd.
Could you have them send you a more detailed report of exactly what it is they are doing, as well as browser version and computer platform.

Sometimes macs or netscape interpret things differently. If we can reproduce the error we can diagnose it.

-Joseph Pishgar

"Re: Illegal referer"
Posted by Bill Weiner on at 05:10 AM
The first thing I would check is that they are linking to your site/script via the exact same URL that you configured in configuration question #5 ($script_url). That is, if that URL has the "www" in it...then make sure they are linking with that "www" in it. Or if your script is on a public server... make sure they are not linking via "https".

Otherwise, yes, it would be helpful to know what browser/OS they were using when they get the "illegal referrer" error.

And it would also be helpful to know if they also got the error when just moving to different weekly schedules (via the "Next" and "Previous" buttons). Or was it just when trying to make a reservation?

But in any case, what you can do for now is to disable the referring page check by following the instructions below. That referral check is just an extra security precaution... but is not necessary since we validate ALL USER INPUT anyway.


STEP 1: Make a backup of your current ureserve.pl script...just in case.

STEP 2: Open your ureserve.pl script with any text editor such as WordPad.

STEP 3: Do a "search" in script for the line that starts with the following text:

&missing_input("Illegal Referrer Page"

(There is only one occurance of that line).

STEP 4: Comment that line out by adding a "#" sign in front of it, like this:

#&missing_input("Illegal Referrer Page"

STEP 5: Save the script (as TEXT if your editor asks)... and try it out!

""Re: Illegal referer""
Posted by David Schrimpf [david_schrimpf@link.freedom.com] on at 11:44 AM
Thanks for the replies.

I'm trying to get the platform/browser info out of them and I'll post it here when I get it. I'm pretty sure they are at the exact same URL as I entered in question #5, but I will check on the https thing.

Meanwhile, I am using the 1.01 version of the script which you emailed me and which displays times in normal 12 hour time. I'll try commenting out that same line and see what happens, but if you have different instructions for this version, please let me know.

Thanks again for all your help.

"""Re: Illegal referer"""
Posted by David Schrimpf [david_schrimpf@link.freedom.com] on at 11:57 AM
I forgot to mention that they also get the error when they click the "Next week" and "Previous week" buttons.

I just commented out that line in my version of the script and the script still works for me... I'm going to have them try it now.

""""Re: Illegal referer""""
Posted by David Schrimpf [david_schrimpf@link.freedom.com] on at 03:34 PM
Just wanted to follow up on this...

I commented out the line and it's all working for them now.

I still wonder why the problem cropped up so suddenly after months of use, and I suspect it was something to do with their network, but their IT people were not helpful.

Anyway, thanks for the support!

"Re: Illegal referer"
Posted by Bill Weiner on at 05:04 AM
Thanks for the feedback.

My guess is that their browser is not setting the HTTP_REFERER environment variable for some reason.... i.e., maybe there is some security setting on the browser now that causes the HTTP_REFERER environment variable to not get set. We'll continue to look into... and if you do find out their browser/OS that would help too.

In any case, glad it's working for you now.