URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_place_order
Thread Number: 137
[ Go back to previous page ]

Original Message
"switched to new host"

Posted by Norma Scott [scott@thesteelsource.com] on at 08:12 PM
I recently switched website hosts. I took advantage of the new setup to start using the latest uShop, I had been using an early version of 3. Finally got some kinks out of it, but when I try to place an order I get to the review page, then when say "continue", it tries to access the perl file on the old website host secure server. That's a big confusing because I didn't upload any of the shopping cart files from the old host. I started off from scratch. Where's that URL hiding? The site is being tested at: Thank you.

Table of contents

Messages in this discussion
"I got that part."
Posted by Norma Scott [scott@thesteelsource.com] on at 08:51 PM
Whoops. I figured out that part. But now I can't get the graphic to show on the shopping cart page. The one that says to place an order.

"RE: I got that part."
Posted by Joseph Pishgar [support@uburst.com] on at 01:09 PM
Well, that graphic not appearing could indicate one of a few problems.

1)The applet was not uploaded in BINARY as opposed to ASCII.
2)The demo_order_button.gif is not in the right place. You might want to double check that its in the classes directory with your applets, so that it can be referenced correctly.
3)Width and Height parameters are set wrong and messing up the applet. Try using WIDTH=228 HEIGHT=92 and see if that helps.

Hope this helps.

Joseph Pishgar
Microburst Technologies, Inc.

"one more question"
Posted by Norma Scott [scott@thesteelsource.com] on at 04:58 PM
Thank you. Reuploading the applets in Binary did the trick. One more thing: On the new Unix server, we are not receiving the order email. I asked the website host how to set the email path and they said:
That should already be set. It should be sendmail and the sendmail path set
at /usr/sbin/sendmail

Is this going to work? It doesn't work right now, although that may be because the site on the new server isn't "live" yet.

"RE: one more question"
Posted by Joseph Pishgar [support@uburst.com] on at 01:56 PM
Glad that worked!

As for sendmail-
Question #7's answer in your ushop.pl file should read-

$email_method = "SENDMAIL";

And question #8 should read-

$sendmail_path = "/usr/sbin/sendmail";

Double-check that both of those paths are indeed correct, and re-upload in ASCII and set permissions. Also, make sure that the contact information in your uShop control panel is set correctly (with the correct e-mail address). Additionally, if you are using the name of a domain recently registered, you *will* have to wait until the domain has propagated through the web before you start getting e-mail from it.

Hope this helps.
If you have any further questions, don't hesitate to fire them our way.

Joseph Pishgar
Microburst Technologies, Inc.

"order email not working"
Posted by Norma Scott [scott@thesteelsource.com] on at 09:55 AM
This is what my host said:
"I noticed that. I think the problem is the way the form template is set up.
Where it asks for billing_email and shipping_email it should just say email.
This is a quirk with the qmail system on the old servers. I just uploaded a
corrected version of this and hopefully it fixes the problem. I can not test
it myself because unfortunately my cable modem provider has not yet updated
their DNS so I am still getting your old site."

We are getting the email at the alternate email address, but not the main one. Any ideas?

"RE: order email not working"
Posted by Joseph Pishgar [support@uburst.com] on at 01:43 PM
Hello Norma,

In the uShop General Settings under E-Mail Notifications there are fields which you can enter your new e-mail address at. I recommend changing these to the new address, if you are still getting e-mail from the *other* address and wish it to change.

Hope this helps.

Joseph Pishgar
Support Engineer
Microburst Technologies, Inc.

"still email problem"
Posted by Norma Scott [scott@thesteelsource.com] on at 05:31 PM
Maybe I'm not explaining this properly. We're not getting the Order Notification at all, even though I have it clearly set in the General Settings. I even changed it back from the new email address I had set up to our tried and true long-used email address. Still no email. The old host was an NT server, so we used sockets. The new one is Unix, so are using sendmail, but I started with a clean install, so no old info is in it.
The really strange thing is that the alternate email address,a yahoo address,works and receives the messages. But we don't want to use the yahoo account. We want to use our pop3 account.
Any ideas you have are eagerly accepted.

"RE: still email problem"
Posted by Joseph Pishgar [support@uburst.com] on at 12:31 PM
Hello Norma,

Hmm. I think I may have an idea of what it is your problem may be. Have you checked your uShopOrderButton script path? It may be referencing the script on your older server.
If thats not it, go ahead and fill out a support request at www.uburst.com/supportform.html and we'll see if we can't diagnose your site that way.

Additionally, if you are comfortable with it, go ahead and include your script path URL and password in the support request, and we'll check your settings from the source.

Joseph Pishgar
Microburst Technologies, Inc.