URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_place_order
Thread Number: 130
[ Go back to previous page ]

Original Message
"mail problems"

Posted by P Pierce [mitzy@capri123.com] on at 11:03 AM
I have my store almost ready to go. When I place an order tho, it does show up in the control panel, but the mail doesn't work. I didn't get a confirmation in the address I used to place the order, nor an order notification in either e-mail addresses I used. I have an UNIX server and sockets e-mail. On the order notification, I used my server e-mail as well as a hotmail account.

Please help

Also, one more question. Should I remove all of the comments from the .pl pages?

Table of contents

Messages in this discussion
"RE: mail problems"
Posted by Bill Weiner on at 11:21 PM
In regard to the email problem, here are a couple suggestions:

1) Since you have a Unix server... it is really recommended that you use the "sendmail" email option to send email. "sendmail" is on all Unix server and pretty much always works.

2) Otherwise, if you still want to try to get the SOCKETS email option working on your Unix server, then you may have to change some of the SOCKET settings in the script. That is, open your ushop-lib.pl script and locate the following 5 lines near the top of the script:

#use Socket;
$AF_INET = 2;

Try uncommenting the first 3 lines and commenting out the last 2 lines... by adding/removing # signs as shown below:

use Socket;
#$AF_INET = 2;

This is often necessary to get the SOCKETS email option to work on Unix servers. (But again, since you have a Unix server, I would really suggest just going with the "sendmail" email option.)

In regard to removing comments from the scripts... no, you shouldn't do that.

Posted by JJ's Cottage [jjscottage@aol.com] on at 11:00 AM
I don't know if this will help...BUT

with my particular server it was specified in the "users manual" that the path for SENDMAIL was

/usr/sbin/sendmail -t

HOWEVER...using that only gave me grief...diagonostic said it was invalid, it didn't send to the specified email address, etc.

So...in doubt and confused I resorted to the uShop.pl default setting of


viola! It worked. Bizarre, because by normal reckoning, it shouldn't. go figure....

Don't take it a "gospel" though. I'm here today trying to find a solution for a different problem, that "shouldn't" be related, but might be....


"Thank you"
Posted by P Pierce [mitzy@capri123.com] on at 03:42 PM
Thank you , problem solved.

"Still cannot get email to work"
Posted by kepitech [kepij@kepitech.com] on at 01:26 PM
When clicking to submit by credit card, or contact us, the order is placed in the Log, however there is no email being sent out.

I found this question here and i tried the first option, making the changes, that didnt work.

I checked the path and it seems to match "/usr/lib/sendmail".

I'm not sure what to do next to get email sent out.

thank you.

"RE: Still cannot get email to work"
Posted by Bill Weiner on at 05:22 AM
So you have a UNIX-type server and are using the SENDMAIL option to send email?

If so, and if you are sure that you path to sendmail is correct, then you may want to try removing the "-t" option as mentioned above.

To do that:

STEP 1: Make a backup of your current ushop-lib.pl script... just in case.

STEP 2: Open your current ushop-lib.pl file with any TEXT editor such as WordPad.

STEP 3: Do a search on the following line:

$mail_program = $sendmail_path . " -t";

STEP 4: Change that line to:

$mail_program = $sendmail_path;

STEP 5: Save the script... as TEXT if your editor asks... and try it out!

"still having trouble"
Posted by kepitech on at 12:39 PM
When I took out the -t part of that command and pressed on "Contact Me", the following was printed out on the top of the resulting page saying that my order was sent.

ste17840... Recipient names must be specified ste17840... Recipient names must be specified ste17840... Recipient names must be specified Content-type: text/html

So then i went into the Control Panel to look at the emails to be sent to and I could not get into "Email notification". Every other tab worked except for that one.

So then i went back and re-ftp'ed the original ushop-lib.pl file. Email notification came up. I tried the process but it gave me a sendmail order. I took out the '-t' and it gave me the same error above.

I have played with the "-t" option in both ushop.pl files but have not gotten one way to work.

Still unclear what to do. I wonder if you have any other suggestions?

Thank you.

"RE: still having trouble"
Posted by Bill Weiner on at 03:56 AM
Based on the "Recipient names must be specified ste17840" error messages that you were getting... it kind of sounds like the modification to remove the "-t" may resolve the problem for you... but that you may not have a "Primary Email" address specified on the "Email Notification" control panel. Have you configured a primary email address on the "Email Notification" panel?

Also, if the "Email Notification" panel was not coming up after you made the "-t" mod... then something else must have accidentally gotten changed in the script when making that mod. Maybe try again with a fresh copy of the script.

And also, from the uShop Control Panel try pressing the "Diagnostics" button and then the "Email Test" button (which is located at the bottom of the Diagnostics output). Do you then get an email sent (and received) to your "Primary Email" address?

If that Diagnostics email test does not reveal the problem for you... send us your Diagnostics output to support@uburst.com... and we'll check out your settings.

"Still not working"
Posted by kepitech on at 03:21 AM
I am still having the same exact problem and am not sure how to get email to actually be sent when it says it is sending email.

I have been testing sendmail with the 'Email Test' button as suggested.

I have tried the following:


all of the following with one of the following two lines in here:

$mail_program = $sendmail_path;
$mail_program = $sendmail_path . " -t";


then I tried each of the following with the above two choices:

$sendmail_path = "/usr/lib/sendmail";
$sendmail_path = "/usr/lib/sendmail ";
$sendmail_path = "/usr/lib/sendmail -t";
$sendmail_path = "/usr/lib/sendmail -t ";
$sendmail_path = "/usr/lib/sendmail -f";
$sendmail_path = "/usr/lib/sendmail -f ";
$sendmail_path = "/usr/lib/sendmail -f myemail@mysite.com";
$sendmail_path = "/usr/lib/sendmail -f myemail@mysite.com ";
$sendmail_path = "/usr/lib/sendmail -t -f myemail@mysite.com";
$sendmail_path = "/usr/lib/sendmail -t -f myemail@mysite.com ";

The only way I can get the message that email has been sent is from

$sendmail_path = "/usr/lib/sendmail";

When I ask the isp for help they say use the -f option with email, but i have asked more than once and received different responses.

I really don't know what to do. What could be the reason the program thinks email is being sent but it is not? Maybe that could help me know where to pursue.

Thank you very much for your help.

"RE: Still not working"
Posted by Bill Weiner on at 04:59 AM
First off, it won't do any good to add the additional parameters to your "$sendmail_path" configuration question.... unless you first removed the " -t" option from the $mail_program line as described in my May 20th posting above:

$mail_program = $sendmail_path;

Also, I believe the -f option would only "override the default sender email address " ... which I can't see how that would effect the whether the email is sent or not. Furthermore, that -f email address must be known to the server... so if it isn't that could cause a problem right there. Unless they say for sure that you need to use the -f option, I wouldn't recommend using that.

And also in regard to the -f option, if you put any email addresses after that in the $sendmail_path line, you'll need to "escape" the ampersand in the email address with a backslash, such as:


.... because in Perl any special characters (such as the ampersand) must be "escaped" when it is used within double quotes.

Anyway, here is what I would suggest:

Step 1: Return the "$sendmail_path" to just:

$sendmail_path = "/usr/lib/sendmail";

Step 2: Keep the " -t" removed from the "$mail_program" line as described in my May 20th posting above:

$mail_program = $sendmail_path;

Step 3: Make sure that the "Primary Email Address" that you are testing with (and which is configured on the uShop Control Panel under General Setting - Email Notifications) is an email address that is known to your server.

Step 4: And test that out.

If that doesn't work, then try the SOCKETS email method, by:

Step 1: Set the "$email_method" configuration question at the top of the ushop.pl script to "SOCKETS":

$email_method = "SENDMAIL";

Step 2: Change these socket settings located near the top of the ushop-lib.pl script:


#use Socket;
$AF_INET = 2;


use Socket;
#$AF_INET = 2;

Step 3: And test that out.

If neither of the above options work, then send me your diagnostics output (to support@uburst.com) ... and I'll check out your settings.

"it works but it doesn't"
Posted by kepitech on at 03:44 AM
Great news....the Diagnostics Mail Test works!!!

however, going through the whole order process and then clicking on "Contact Me", I get

"Configuration Error - Unable to connect to Socket"

Any further suggestion?

Thank you.

"RE: it works but it doesn't"
Posted by Bill Weiner on at 04:50 AM
The final step of the "Contact Me" payment process uses the EXACT SAME subroutine as the "Diagnostic Email Test" ... with the only difference being email address of the customer (the storeowner's email address will be the same).

As a test, try placing an order and specify the storeowner's email address as the customer's email address and see if you still error.

If you do, then send as a support request with your "Diagnostic Output", your uShop Control Panel Password, and the URL of your store pages so that we can see the configuration and problem ourselves.

"I got it Thank you!"
Posted by kepitech on at 12:30 PM
I was processing the order without an email address. It seems it requires one to go through.

"RE: I got it Thank you!"
Posted by Bill Weiner on at 05:11 AM
Great! Glad it's working for you now.

"Well not totally"
Posted by kepitech on at 05:04 PM
I can get it to work with Sockets, but not if I use an email with the domain name that the site is at.

It would be much preferable to do so. Is it possible?

Thank you very much.

"Email with Sockets "
Posted by Microburst Support Team [support@uburst.com] on at 11:29 AM
If you can get it to work with sockets, it SHOULD work for any email with the domain name that the site is at. Have you run a diagnostic report?

Send it to us to take a look (support@uburst.com)