URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: uReserve_troubleshooting
Thread Number: 12
[ Go back to previous page ]

Original Message
"Error: Illegal Referer Page"

Posted by Walter Cecchini [cecchini@nortelnetworks.com] on at 09:29 AM

I am having the same issue with ver2.0 as with the previous version. Fairly frequently when I try to move to the next or previous week by clicking the buttons or entering a new date, I get a page that says "Illegal Referrer Page: the referring page did not meet security requirements, click here to go back."

I don't know what causes this or 'resets' it but I'll go in 15 minutes later and it will be fine.

Any light on this would be greatly appreciated.

Table of contents

Messages in this discussion
"Re: Error: Illegal Referer Page"
Posted by Joseph Pishgar [support@uburst.com] on at 12:46 PM
Hello Walter,

Is your version of uReserve installed on a secure server or are you trying to go from a secure page to an unsecure uReserve?

Joseph Pishgar
Support Engineer

"Re: Error: Illegal Referer Page"
Posted by Bill Weiner on at 08:54 PM
What is the URL that you have configured in configuration question #5 at the top of the ureserve.pl script ($script_url)? Whatever URL you are using there... is the URL by which you should be linking to the script.

For example, if you configured that question as something like:

$script_url = "http://www.yourdomain.com/cgi-bin/ureserve.pl";

Then be sure to use that URL when linking to your script.

And be sure that if you specify the "www" in your domain name... that you indeed use "www" when linking to the script (as opposed to just linking to yourdomain.com without the "www").

"Illegal Referrer Page"
Posted by Walter Cecchini [wcecchini@yahoo.com] on at 09:14 PM

I think this solved my problem! I wasn't using the FULL URL when running the script.

Since I changed it, I haven't had this problem occur.


""Re: Error: Illegal Referer Page""
Posted by David Schrimpf [david_schrimpf@link.freedom.com] on at 06:32 PM
I have a client using a reserve script that I set up. They have been using it for a few months with no problems but today they started getting this illegal referer error.

They click on the name of the resource to bring up the small window. They fill in the appropriate information and click the "Reserve" button. That is when the error appears.

I just noticed that when you click on the name of the procedure on a certain day, it adds "#DAY2" to the URL. Could that be causing the illegal referer?

For what it's worth, it works perfectly from my location every time, but hasn't worked for them at all today.

Thanks in advance for any help

"Re: Error: Illegal Referer Page"
Posted by Bill Weiner on at 05:12 AM
The first thing I would check is that they are linking to your site/script via the exact same URL that you configured in configuration question #5 ($script_url). That is, if that URL has the "www" in it...then make sure they are linking with that "www" in it. Or if your script is on a public server... make sure they are not linking via "https".

(Note that the #DAY2, #DAY3, .... text at the ends of the URL is not a problem... so don't worry about that.)

Otherwise, it would be helpful to know what browser/OS they were using when they get the "illegal referrer" error.

And it would also be helpful to know if they also got the error when just moving to different weekly schedules (via the "Next" and "Previous" buttons). Or was it just when trying to make a reservation?

But in any case, what you can do for now is to disable the referring page check by following the instructions below. That referral check is just an extra security precaution... but is not necessary since we validate ALL USER INPUT anyway.


STEP 1: Make a backup of your current ureserve.pl script...just in case.

STEP 2: Open your ureserve.pl script with any text editor such as WordPad.

STEP 3: Do a "search" in script for the line that starts with the following text:

&missing_input("Illegal Referrer Page"

(There is only one occurance of that line).

STEP 4: Comment that line out by adding a "#" sign in front of it, like this:

#&missing_input("Illegal Referrer Page"

STEP 5: Save the script (as TEXT if your editor asks)... and try it out!