uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Problem and a question

Knowledge Base Lobby : uShop Support Conference : General Questions
Mar-23-18 09:13 AM EST
Original Message
Problem and a question
Author Duster on 06-14-2000 at 03:11 (EST)
I just got the full version of the program for a client and can really appreciate the ease with which it can be set up and it works. What a joy.

I do have one remaining problem. When trying to use the Order Reader applet, after attempting to retrieve an order, I get an error message "orders directory not found". There are orders in there, which I have verified through FTP, so the other part sof the program know where the orders directory is. Any idea how to fix this problem?

Moving on to my question, is there an order applet that will add a service charge if the order total is below a specified amount? I looked, and didn't find that feature.

If there isn't, please consider it a request. For instance, being able to add a $5 service charge for all orders under $50. (exclusive of shipping, taxes, and any other fees).

Table Of Contents
  RE: Problem and a question Bill Weiner, 2000-06-14 06:38:22 (1)
            Problem still there Duster, 2000-06-14 12:31:31 (3)
                 RE: Problem still there Bill Weiner, 2000-06-14 12:48:49 (4)
  Thank you Duster, 2000-06-14 12:26:38 (2)

Messages In This Discussion
         1. RE: Problem and a question
        Author Bill Weiner on 06-14-2000 at 06:38 (EST)
Thanks for the complements!

In regard to your questions:

1) If orders are successfully being written to your orders directory...but the order reader is not finding them (or the actual directory), then the problem is usually that the order applet is not pointing to the same script that the order applet is using. That is, make sure that the "scriptpath" parameter of your uShopOrderReaderCGI applet is set to EXACTLY the same "scriptpath" value of your uShopOrder applet.

2) In regard to a service charge if the subtotal is less than a specified amount. The only solution we right now, is the uShopDiscount1 which case, you can give a discount if the subtotal is above a specified amount.

For example:


Save $5.00 on orders over $50.00!

APPLET CODE = "uShopDiscount1.class" WIDTH=205 HEIGHT=190
PARAM NAME=image VALUE="example_discount.gif"
PARAM NAME=rate VALUE="$50=$5"


So maybe you can try configuring a solution with that applet?
                 3. Problem still there
                Author Duster on 06-14-2000 at 12:31 (EST)
No, that's not it. The path is identical in all instances. It has to be something else.
                         4. RE: Problem still there
                        Author Bill Weiner on 06-14-2000 at 12:48 (EST)
The ushop_cgiscript does not ever output the message "orders directory not found" if that is the message you are seeing, you server is generating it.

If that is not the message you are actually seeing, give me the exact message.

If that really is the message that you are seeing - and the "scriptpath" parameter of both your order applet and your order reader applet are exactly the same - then as a foolproof method, try putting the full directory path in your "$order_directory" parameter.

Otherwise, submit a support request with your URL and your order reader password so that I can try it out and see what is happening.
         2. Thank you
        Author Duster on 06-14-2000 at 12:26 (EST)
Thank you. I had thought of a discount as an alternate method of accomplishing it, and will try that.

© 2003 Microburst Technologies, Inc.