uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
UshopInput3 applet works w/IE not Netscape

Knowledge Base Lobby : uShop Support Conference : General Questions
Mar-19-18 04:51 AM EST
Original Message
UshopInput3 applet works w/IE not Netscape
Author W. C. Golden, Sr. on 09-28-2002 at 10:49 (EST)
On our site we have a link to '2000' pieces of hardware which uses the applet and works with Netscape and one to 1100 books that uses the same applet that does not work. They BOTH work with IE. Any suggestions??

Table Of Contents
  RE: UshopInput3 applet works w/IE not Netscape Bill Weiner, 2002-09-30 04:32:06 (1)
            Applet works in IE not in Netscape W. C., 2002-10-03 16:48:43 (2)
                 RE: Applet works in IE not in Netscape Bill Weiner, 2002-10-04 05:19:47 (3)
                      -same- W. C., 2002-10-04 16:26:38 (4)
                           RE: -same- Bill Weiner, 2002-10-08 05:09:14 (5)

Messages In This Discussion
         1. RE: UshopInput3 applet works w/IE not Netscape
        Author Bill Weiner on 09-30-2002 at 04:32 (EST)
Some browsers are less forgiving of HTML syntax error than others, so make sure the HTML of the 1100 books applet (and the HTML around the applet) is correct. Ie. Any HTML tags have the appropriate closing tags, parameters are in the correct format, etc.

If that doesn't resolve the problem, then give me the URL of the page with the problem and I'll take a look at it.
                 2. Applet works in IE not in Netscape
                Author W. C. on 10-03-2002 at 16:48 (EST)
The calling frame that calls the book frame is and the displayed results is a modified display_product.html stored at
which is used as the results frame for hardware (

Note: there are no graphics file for the books as there is for hardware. It does work in IE but not Netscape.

Thanks for any help.
                         3. RE: Applet works in IE not in Netscape
                        Author Bill Weiner on 10-04-2002 at 05:19 (EST)
I see a couple things that could cause the problem:

#1) The codebases of your applets are not exactly the same.


They might translate to be the same directory, but some browsers will not treat them all as being exactly the same. Refer to:

For a complete description of the codebase parameters.

But before messing around with the codebase settings, check out #2 below:

#2) Considering that you are using the search applets and from looking at your "display_product.html" page... it appears you are not using the latest uShop update.

You should be using at least version 3.45 or later.

As part of this update, you will actually have two display_product pages (display_product.html and display_product2.html)... which I don't see on your site at:

So I would first recommend upgrading to the latest version of uShop (uShop 3.45 or later) and see if that resolves the problem.
                                 4. -same-
                                Author W. C. on 10-04-2002 at 16:26 (EST)
Updated to 3.5. Now in Netscape and IE only the hardware works, the book search does not work in either. The codesource is the same "./java/" in both. Could it be because there are not graphics for the books?

Also, what is the 2nd display_product html for?
                                         5. RE: -same-
                                        Author Bill Weiner on 10-08-2002 at 05:09 (EST)
The two "display_product" and "display_cart" pages that are included with uShop 3.5 are designed to handle different browser, JVM, and Java Plug-in differences.

Looking at your display_product pages at:

I see the uShopJSI applet of one page has a codebase setting of:


While the uShopJSI applet of the other page has a codebase setting of:


See the following URL for the recommended directory structure/codebase setting:

© 2003 Microburst Technologies, Inc.