uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
problems with perl and

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Mar-20-18 10:59 PM EST
Original Message
problems with perl and
Author Jeremy on 08-21-2002 at 23:02 (EST)
I get this error when I run the
Any ideas?

Hooray! It works!
perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LC_ALL = (unset), LANG = (unset) are supported and installed on your system. perl: warning: Falling back to the standard locale ("C").

Table Of Contents
  RE: problems with perl and Bill Weiner, 2002-08-22 04:51:19 (1)
            UNIX variables? Jeremy, 2002-08-22 10:54:35 (2)
                 RE: UNIX variables? Bill Weiner, 2002-08-23 04:18:47 (3)

Messages In This Discussion
         1. RE: problems with perl and
        Author Bill Weiner on 08-22-2002 at 04:51 (EST)
That error really has nothing to do with uShop... but from experience, I recognize LC_ALL and LANG as two standard Unix enviroment variables ... which sound like their not getting set on your server... or at least not in the shell that Perl is being executed in. I would suggest just contacting your web hosting provider ... showing them the error that you are getting with that very basic test CGI script. They should be able to recognize/resolve the problem.
                 2. UNIX variables?
                Author Jeremy on 08-22-2002 at 10:54 (EST)
Unfortunatly I have set this up on a windows 2000 advanced server to test this software on.

I just did a standard install of perl, does perl need to be configured? It seems to work other that adding the error at the bottom..

Any more ideas?
                         3. RE: UNIX variables?
                        Author Bill Weiner on 08-23-2002 at 04:18 (EST)
I know those are environment variables in Unix environments... but I don't know about Windows servers. Based on your error message, it sounds like your Windows installation of Perl is trying to set (or unset) those environment variables... so maybe check your Win 2000 settings and see if those environment variables are being set (I think environment variables on Win 2000 machines can be found under Control Panel - System).

Otherwise, I would suggest searching on the web for the answer. I did a quick search with Google on "perl: warning: Setting locale failed" ... and there were many, many results. So you're not the first to experience a problem like that with your installation of Perl. I would suggest reading through those links and finding one that corresponds to your system configuration.

© 2003 Microburst Technologies, Inc.