uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
BUG...

Knowledge Base Lobby : uStorekeeper Support Conference : Configuration Questions
Dec-11-17 10:28 AM EST
Original Message
BUG...
Author Bradley Edwards on 01-28-2002 at 00:11 (EST)
Support,

I just found a bug in the import function of the utorekeeper. No big deal, I couldn't figure out why everytime I would Import my db file, the text for the bottom HTML was missing.

in the "import_data_file" sub

there is only 22 items (0-21), it was missing the last item on import.

I just changed the last lines, from:

$key_value_pairs[20],
$key_value_pairs[21])== 1)

to:

$key_value_pairs[20],
$key_value_pairs[21],
$key_value_pairs[22]) == 1)

And all is great. My version, is "1.81"

Regards,
-Brad Edwards

E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: BUG... Bill Weiner, 2002-01-28 06:31:34 (1)
            Another Bug Bradley Edwards, 2002-03-19 20:00:00 (2)
                 RE: Another Bug Bill Weiner, 2002-03-19 22:02:16 (3)
                      RE: Another Bug Bradley Edwards, 2002-03-20 15:50:53 (4)

Messages In This Discussion
         1. RE: BUG...
        Author Bill Weiner on 01-28-2002 at 06:31 (EST)
I took a quick look at that subroutine and you may be right. We'll check into some more. Thanks for bringing that to our attention.

If it is missing that last field on the "Import Utility", it probably hasn't been noticed since that last field is the rarely-used "BOTTOM HTML" field... but we'll check into it.
TABLE OF CONTENTS
                 2. Another Bug
                Author Bradley Edwards on 03-19-2002 at 20:00 (EST)
Bill,

Here are 2 more things that I found within uStoreKeeper. Nothing major, the first is a bug that lets someone submit an order without putting in thier 'State' - No 'State' no tax!

Under 'sub review_order', I added the following:

if (!($customer_state =~ /S/))
{
&missing_input("Missing Input","Please enter your *State.");
}

between City & Zip Code.

And the other bug, will let someone submit thier 'E-check' order without inputting the 'Transit Code'.

Under the 'sub electronic_check_order', added the following:

if (!($echeck_transit_code =~ /S/))
{
&missing_input("Missing Input","You must enter the Transit Number.");
}

after all the others.

-Brad
TABLE OF CONTENTS
                         3. RE: Another Bug
                        Author Bill Weiner on 03-19-2002 at 22:02 (EST)
Actually, we purposely do not require the "state" because customers from other countries do not have "states".

And same goes for the check "transit code". Based on the electronic check specs, that is not always a required field.
TABLE OF CONTENTS
                                 4. RE: Another Bug
                                Author Bradley Edwards on 03-20-2002 at 15:50 (EST)
Sorry,

In my personal situation, I would probably not be dealing with other countries, so I would rather have them be required.

Thanks,

-Brad
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.