uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Problem with initialze applet

Knowledge Base Lobby : uShop Support Conference : Tax, Shipping, and Handling Questions
Dec-18-17 01:56 AM EST
Original Message
Problem with initialze applet
Author Rita on 09-09-2000 at 09:22 (EST)
Bill,

as you adviced I use the initialize applet to override the "Shipping&Handling" verbage. My applet setup looks like this:



I first had it on the page where the orderbutton applet is - but found that the program flow stalls occasionally. So I put the initialize applet on my cart entry page. But the problem is the same.
The page with the orderbutton applet shows in the status bar that the applet is running. But when clicking on it to start the order process everything is stalled and the customer sits on that page and cannot go on further. If the initialize applet was not called before, the order flow is correct and reliable again.

This happens with Netscape 4.72 and Internet Explorer. I cleared the cache, restarted browers ... but the result is the same: as soon as the initialize applet was called before the "start order process" sometimes works, but mainly not.

So - what can be done?
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Problem with initialze applet Bill Weiner, 2000-09-09 13:22:13 (1)
            Initialize applet Rita, 2000-09-11 01:37:10 (2)

Messages In This Discussion
         1. RE: Problem with initialze applet
        Author Bill Weiner on 09-09-2000 at 13:22 (EST)
So you are saying whenever the uShopInitialize applet is used....whether it is on the same page as the uShopOrderButton or not... the order process gets messed up? Give me the URL and I will take a look at it.

In the mean time, I would suggest checking out the uShopInitialize applet at our online applet reference:

http://www.uburst.com/uShop/reference/applets.html

And then pressing the "uShopOrderButton" there to verify that it properly works there.... Then compare the parameters and see what could be causing the problem for you.

But again, send me the URL and I will take a look at it.
TABLE OF CONTENTS
                 2. Initialize applet
                Author Rita on 09-11-2000 at 01:37 (EST)
The cart behaved exactly as you described.
BUT ... I updated the scripts to version 3.1 now. Though the mentioned bug fixed actually should not touch my previous problem: my cart (if using the initialize applet) is working now. Weird, but of course I am glad it is ok now.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.