uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Strange Symbol ( )

Knowledge Base Lobby : uShop Support Conference : General Questions
Dec-12-17 01:09 PM EST
Original Message
Strange Symbol ( )
Author Julian on 08-02-2000 at 10:05 (EST)
Hi

We are working on an upgrade of uShop (V3) for a client but when the Order Information page is displayed with the HTML cart below, an symbol appears before the symbol.

This is also displayed on the order "Thank You" page and when we read the order via the Order Reader.

We have checked the settings in ushop-languages.pl and $lang_currency_symbol = '';

Please help!
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  strange symbol Charlie Edmunds, 2000-08-02 17:56:58 (1)
            Strange Symbol ( ) Julian, 2000-08-03 13:38:38 (2)
                 RE: Strange Symbol ( ) Bill Weiner, 2000-08-04 10:21:27 (3)
                      Strange Symbol ( ) Julian, 2000-08-04 11:05:12 (4)
                           RE: Strange Symbol Bill Weiner, 2000-08-04 12:36:34 (5)
                                Strange Symbol ( ) Julian, 2000-08-04 13:45:08 (6)
                                     RE: Strange Symbol ( ) Bill Weiner, 2000-08-04 15:00:30 (7)
                                          Strange Symbol Julian, 2000-08-04 15:36:16 (8)
                                               RE: Strange Symbol Bill Weiner, 2000-08-05 07:44:37 (9)
                                                    Strange Symbol ( ) Julian, 2000-08-05 10:02:15 (10)
                                                         Strange Symbol ( ) Julian, 2000-08-05 10:26:48 (11)
                                                              RE: Strange Symbol ( ) Bill Weiner, 2000-08-06 08:15:31 (12)
                                                                   Strange Symbol ( ) Julian, 2000-08-07 08:19:11 (13)
                                                                        Strange Symbol ( ) Julian, 2000-08-08 09:49:55 (14)
                                                                             RE: Strange Symbol ( ) Bill Weiner, 2000-08-08 14:21:39 (15)
                                                                                  RE: Strange Symbol ( ) Bill Weiner, 2000-08-10 06:28:32 (16)
                                                                                       RE: Strange Symbol ( ) Bill Weiner, 2000-08-11 05:26:40 (17)

Messages In This Discussion
         1. strange symbol
        Author Charlie Edmunds on 08-02-2000 at 17:56 (EST)
Hi Julian,

Just want to verify that you uploaded all but your class files in text mode and your class files in binary mode.

Julian, can I have the url for your site so I can take a look at it?

Thanks, Charlie Edmunds
TABLE OF CONTENTS
                 2. Strange Symbol ( )
                Author Julian on 08-03-2000 at 13:38 (EST)
Please refer to my email response to the above.

Thanks
Julian
TABLE OF CONTENTS
                         3. RE: Strange Symbol ( )
                        Author Bill Weiner on 08-04-2000 at 10:21 (EST)
Give me the URL and I will take a look at it.
TABLE OF CONTENTS
                                 4. Strange Symbol ( )
                                Author Julian on 08-04-2000 at 11:05 (EST)
Hi Bill

I sent an email with the licence no and URL.

The test site is at http://www.yourservice.co.uk/test01/html/index.html

The scripts reside on our secure server at https://secure.yourservice.co.uk/cgi-bin/test01/

Regards
Julian
TABLE OF CONTENTS
                                         5. RE: Strange Symbol
                                        Author Bill Weiner on 08-04-2000 at 12:36 (EST)
I see you have a codebase problem on your "display_cart.html" page. Please change the codebase on that page back to "../codebase/" and then I'll be able to continue looking at the site.
TABLE OF CONTENTS
                                                 6. Strange Symbol ( )
                                                Author Julian on 08-04-2000 at 13:45 (EST)
I presume that you mean to change the codebase to "../classes/" as with all the applets...I've done that now.
TABLE OF CONTENTS
                                                         7. RE: Strange Symbol ( )
                                                        Author Bill Weiner on 08-04-2000 at 15:00 (EST)
I just tested out your site (you should be receiving a test order)... and everything worked and appeared fine. I didn't see any strange characters before the "" sign on any of the HTML shopping cart displays. Are you sure you are still receiving the "" symbol?

Try using the order reader to read the order that I just placed....do you see the symbol there?
TABLE OF CONTENTS
                                                                 8. Strange Symbol
                                                                Author Julian on 08-04-2000 at 15:36 (EST)
AAH....I know what it is!!

The UK version of Windows 98/98SE defaults the browser Encoding to Western European (Windows) and this causes the error. It's fine if I change the Encoding to Unicode (UTF-8).

Bearing in mind that we can't ask everyone to change their browser settings, what can be done to resolve this?
TABLE OF CONTENTS
                                                                         9. RE: Strange Symbol
                                                                        Author Bill Weiner on 08-05-2000 at 07:44 (EST)
Hmmmmm.... That is interesting. So you're browser does successfully see symbols like "" when on regular HTML page (like this one), it's just that when that symbol is encoded as in a POST, it is encoded differently. Very interesting.

As a test, try placing an order on your site and view the source on your "Review Order" page. Down near the very bottom (on a very long line), you should see a "hidden" field entitled "currency_symbol". Does it show up as "" or as that weird "" symbol? Based on the information you gave, I'm guessing the "".

Also, are ALL "" symbols on your order forms appearing as ""... or just certain ones?

Let me think about it over the weekend and we'll see what we can do.
TABLE OF CONTENTS
                                                                                 10. Strange Symbol ( )
                                                                                Author Julian on 08-05-2000 at 10:02 (EST)
I have send an email with some screen shots and source code. Hope this helps.
TABLE OF CONTENTS
                                                                                         11. Strange Symbol ( )
                                                                                        Author Julian on 08-05-2000 at 10:26 (EST)
The funny thing is.....when I view your demo site everything is OK. The only difference, of course, is that you are using the US version.
TABLE OF CONTENTS
                                                                                                 12. RE: Strange Symbol ( )
                                                                                                Author Bill Weiner on 08-06-2000 at 08:15 (EST)
Well if the encoding theory is true, that would be because it only affects such non-standard ASCII characters like "" symbols.....Which we do use on our UK Applet Reference at:

http://www.uburst.com/uShop/international/uk/

....which I think will give you the same results that you are seeing on your site.

In any case, we will look into it some more on Monday.
TABLE OF CONTENTS
                                                                                                         13. Strange Symbol ( )
                                                                                                        Author Julian on 08-07-2000 at 08:19 (EST)
Yes... the same problem is experienced at your UK demo site.

Just in case we have tried accessing the site from 4 separate PCs and get the same problem.

Any more suggestions?
TABLE OF CONTENTS
                                                                                                                 14. Strange Symbol ( )
                                                                                                                Author Julian on 08-08-2000 at 09:49 (EST)
Hi Bill

The answer to both your questions is YES - the symbol was displayed correctly.

TABLE OF CONTENTS
                                                                                                                         15. RE: Strange Symbol ( )
                                                                                                                        Author Bill Weiner on 08-08-2000 at 14:21 (EST)
So the tests at:

http://www.uburst.com/uShop/poundtest/

both functioned fine in your browser? Well, that kind of eliminates the encoding problem because the "" sign is being posted in that test the same way uShop POSTs the data in the order process.

Let me take another look at the source code of the pages that you sent and see if I see anything strange.
TABLE OF CONTENTS
                                                                                                                                 16. RE: Strange Symbol ( )
                                                                                                                                Author Bill Weiner on 08-10-2000 at 06:28 (EST)
I took another look at the pages that you sent and still do not know why your browser is displaying that "" symbol before the ""... but as a test, try placing a test order again from our UK Applet Reference:

http://www.uburst.com/uShop/international/uk/reference/

And let me know if you still see that "" on any or all of the order form pages.
TABLE OF CONTENTS
                                                                                                                                         17. RE: Strange Symbol ( )
                                                                                                                                        Author Bill Weiner on 08-11-2000 at 05:26 (EST)
Well, whatever was going on your browser's European Encoding and Java POSTs, we released a work around by not even using the currency symbol POSTed from the Java side for those HTML cart displays.

http://www.uburst.com/uShop/updates.html
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.