uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Secure web server

Knowledge Base Lobby : uShop Support Conference : General Questions
Dec-11-17 08:32 AM EST
Original Message
Secure web server
Author frank luna on 01-18-2001 at 11:02 (EST)
Im not using ushop for online transactions.Does my web server need to be secure to recieve ushop orders?Im running it on a nonsecure web site(intranet) and right now im not getting the order written to the data directory, also no email reciepts because of this.Can you help.
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Secure web server Bill Weiner, 2001-01-18 15:35:58 (1)
            No email,No orders frank luna, 2001-01-18 16:20:16 (2)
                 RE: No email,No orders Bill Weiner, 2001-01-19 14:28:19 (3)

Messages In This Discussion
         1. RE: Secure web server
        Author Bill Weiner on 01-18-2001 at 15:35 (EST)
No, you don't need to have a secure server to just run the scripts.

As per the problem you are experiencing....

So youíre getting all the way through the order process... to the final "Thank You" page... but no order files are being created and no emails are being sent?

Well, letís first focus on the order file problem. It is very strange that no order files are being created in your "data" directory... and yet, you are not seeing any error messages? If an order file is not created during the order process, at the very least you should get an "Unable to Open" error message.

I would normally say that this sort of a problem would be due to your $data_directory setting in your "ushop.pl" script being incorrect.... And to try using the full directory path instead of a relative directory path there. But based on the fact that you are able to set your storeís "General Settings"... And read them back in a Diagnostic Report... that makes things a little strange.

As a test anyway, try changing the $data_directory setting in your "ushop.pl" script from:

$data_directory = "./data/";

to use the FULL DIRECTORY PATH to your data directory... something like this:

$data_directory = "C:/username/cgi-bin/data/";

(Although Iím sure this will be slightly different on your server... just use the full directory path there and see if it helps.)
TABLE OF CONTENTS
                 2. No email,No orders
                Author frank luna on 01-18-2001 at 16:20 (EST)
I configured it just like you said, nothing.Im stumped.The older 2.0 script worked just fine and made orders.Can you call me 602-267-2465.
TABLE OF CONTENTS
                         3. RE: No email,No orders
                        Author Bill Weiner on 01-19-2001 at 14:28 (EST)
I'll send you an email in order to get some additional information that I will need to resolve the problem (Since I can't see it myself on your Intranet).
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.