uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
No SMTP address specified

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Dec-17-17 02:19 PM EST
Original Message
No SMTP address specified
Author Mark Weber on 08-06-2002 at 15:43 (EST)
At the end of the order process when a user clicks the send button a message appears stating: "Configuration Error" No SMTP address specified. I just started having this problem. Everything used to work fine. Not sure if something on the our server has changed. Need some help on what I need to do to correct this problem. Thank You so Much!!!!
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: No SMTP address specified Bill Weiner, 2002-08-07 05:01:16 (1)
            No SMTP address specified Mark Weber, 2002-08-07 07:47:41 (2)
                 RE: No SMTP address specified Bill Weiner, 2002-08-08 05:00:18 (3)

Messages In This Discussion
         1. RE: No SMTP address specified
        Author Bill Weiner on 08-07-2002 at 05:01 (EST)
If you weren't having that problem before... then yes, something on your server definitely changed.

Since the problem sounds to be e-mail related, I would suggest first logging in to the uShop Control Panel and pressing the "Diagnostics" button. From the "Diagnostic" screen, press the "Email Test" button (located at the bottom)... and see if that gives you any more insight into the problem.

I would then suggest checking your email settings in configuration question 7 - 10 of the ushop.pl script and see if those settings need to be updated due to the server configuration change.
TABLE OF CONTENTS
                 2. No SMTP address specified
                Author Mark Weber on 08-07-2002 at 07:47 (EST)
Bill,

I tried using the Email Test from the Diagnostic screen and I get the same result. I get a screen that says "No SMTP address specified." The settings in the ushop.pl have not changed. The mail settings on the server are as follows:

Incoming POP3 Server- mail.safaripet.net
Outgoing (SMTP) Server- mail.safaripet.net

It is a Windows based server and I'm guessing by the above information that it does include a SMTP server. I'm using the "Sockets" set up in the ushop.pl script and that has worked fine up until a few days ago. Any clues on how I can get this back in working order again. Please help!! Thank you so much. I have had a few questions in the past with Ushop and your support has been amazing. Thank You!!

Mark
TABLE OF CONTENTS
                         3. RE: No SMTP address specified
                        Author Bill Weiner on 08-08-2002 at 05:00 (EST)
And so you have configuration question #10 at the top of the ushop.pl script currently set to the following value?

$smtp_address = "mail.safaripet.net";

Maybe try specifying that setting as the actual IP address of your mail server... Or vice-versa, if using the IP address in that setting now, then try using "mail.safaripet.net" instead.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.