uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Server error whith email test

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Dec-13-17 05:28 PM EST
Original Message
Server error whith email test
Author Jean Pierre on 01-31-2003 at 09:11 (EST)
Whith the diagnostic of my control panel the path to sendmail is OK, but when I want to test my email I get an "internal server error"
what is the problem ?
Thank you

I work on an Unix server my path to sendmail is "/usr/sbin/sendmail"
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Server error whith email test Bill Weiner, 2003-02-04 06:45:22 (1)

Messages In This Discussion
         1. RE: Server error whith email test
        Author Bill Weiner on 02-04-2003 at 06:45 (EST)
If the Diagnostic Test indicates that the sendmail path is OK:

Sendmail = Path OK

That means that your current $sendmail_path setting (configuration question #8 at the top of the ushop.pl script) is correct (or at least pointing to a valid file).

----

Now if you are getting a Server Error when just pressing the "Email Test" button on the Diagnostics screen, then that means the problem is one of a couple things:

1) Make sure that you have entered a valid "Primary Email Address" for the storeowner via the uShop Control Panel. The "Primary Email Address" setting can be found on the control panel under GENERAL SETTINGS - EMAIL NOTIFICATIONS.

2) If upon verifying that your sendmail path is correct and you are using a valid "Primary Email Address", you still get a server error when trying the Diagnostic Email Test, then you may need to try removing the default sendmail "-t" option that uShop uses. Below are instructions on how ot remove the "-t" option from sendmail:

STEP 1: Make a backup of your current ushop-lib.pl script... just in case.

STEP 2: Open your current ushop-lib.pl file with any TEXT editor such as WordPad.

STEP 3: Do a search on the following line:

$mail_program = $sendmail_path . " -t";

STEP 4: Change that line to:

$mail_program = $sendmail_path;

STEP 5: Save the script... as TEXT if your editor asks... and try it out!

(Refer to the support forum entry: http://www.uburst.com/dcforum/ushop_place_order/130.html for a similar discussion).
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.