uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
unable to locate order page

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Dec-12-17 01:04 PM EST
Original Message
unable to locate order page
Author webgeek on 06-08-2000 at 14:50 (EST)
Hi, I am testing Ushop on another site. They want to see it before they buy it. Any how I am referencing one of my other site's class directory for the codebase of their scripts. The scripts run just fine, but when I go to the order page I get a "unable to locate order page" error. Funny thing is the order.template page DOES exist in that directory that the script is looking in (and it works). Is this a protective feature of Ushop? If so, great! If not, any ideas why this isn't showing up?

Details:
URL http://www.webgeekdesign.com/mad/
SSL https://webgeek2.virtualis.com/mad/order.template

I have tried both the relative and direct URL without success in the "order_page value="
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: unable to locate order page Bill Weiner, 2000-06-09 05:15:19 (1)

Messages In This Discussion
         1. RE: unable to locate order page
        Author Bill Weiner on 06-09-2000 at 05:15 (EST)
From looking at your website, I notice that you have the "scriptpath" parameter of your uShopOrderButtonCGI applet set to:

https://webgeek2.virtualis.com/cgi-bin/mad/ushop_cgiscript.pl

And you have the "order_page" parameter of that applet set to:

../htdocs/mad/order.template

The problem may just be that since you have the script located in a subdirectory of your cgi-bin subdirectory (cgi-bin/mad/), you just need an extra "../" in your path to get to the order template located in the "mad" subdirectory of your main HTML directory. So in other words, try changing the order_page parameter to:

../../htdocs/mad/order.template

And that may fix it. Otherwise, go ahead and try the full path to that directory (not the full URL)...it will be something like:

/www/htdocs/mad/order.template

But in anycase, provided your order.template file is located on the same server as your ushop_cgiscript, then the ushop_cgiscript should be able to load it....just a case of getting the directory path right.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.