uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
"Content-type" should not appear

Knowledge Base Lobby : uDirectory Support Conference : General uDirectory Troubleshooting
Nov-19-17 01:54 AM EST
Original Message
"Content-type" should not appear
Author Alan Collins on 03-16-2001 at 22:12 (EST)
Simple question: The perl script prints "Content-type: text/html" at the top of each page. This string is appearing on the page when viewed from the browser. Should I just delete it? or change some other setting?

I'm running Apache 1.3 on Linux (RedHat 6.x)
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: "Content-type" should not appear Bill Weiner, 2001-03-18 21:53:25 (1)
            RE: "Content-type" should not appear Alan Collins, 2001-03-19 23:50:10 (2)

Messages In This Discussion
         1. RE: "Content-type" should not appear
        Author Bill Weiner on 03-18-2001 at 21:53 (EST)
Where are you seeing the "Content-type: text/html" being added? To the static HTML pages? Just during the "Search Results" pages? On the control panel pages?

Normally that "Content-type: text/html" needs to be outputted on any dynamically generated page. Depending on when you are actually seeing that text... it sounds like your server is already automatically outputting that "Content-type: text/html" for you for some reason. I've never really heard of a server doing that before... but if you need to... then go ahead and remove the "Content-type: text/html" lines from the script.
TABLE OF CONTENTS
                 2. RE: "Content-type" should not appear
                Author Alan Collins on 03-19-2001 at 23:50 (EST)
I see it on all pages, (including the one from cgitest.pl). I removed all instances of "Content-type" from the .pl file and it is still displaying the page correctly (though I have other problems which I will address separately).
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.