uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Internal server error after display_cart

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Mar-21-18 10:36 PM EST
Original Message
Internal server error after display_cart
Author Cathy on 02-05-2003 at 10:00 (EST)
Hi, my cart has been working fine (except for the odd person) until the last week. Now when you click on the "continue" button from the review order page you get the internal server error page:
"The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."
I am
My secure server is etc.
On February 1st I uploaded new UShopCart3 applets on most pages, with UShopcart1 applets continuing to be in existence (link) on each page. This is the only thing that I know is different.
Thanks very much for your help


Table Of Contents
  RE: Internal server error after display_cart Bill Weiner, 2003-02-06 06:40:20 (1)
            Re:internal error after display_cart Cathy Roberts, 2003-02-09 15:07:17 (2)
                 Re:internal error after display_cart Bill Weiner, 2003-02-10 07:31:34 (3)

Messages In This Discussion
         1. RE: Internal server error after display_cart
        Author Bill Weiner on 02-06-2003 at 06:40 (EST)
I see that by just going to the URL of the uShop CGI script on your website:

... that you get the "Internal Server Error".

This means something relating to your uShop CGI script and/or your server configuration was changed recently.

I would suggest reviewing the "Server Error" tips listed on the following reference page:

Perhaps starting with the "Test Script" described at:

.... just to make sure that some fundamental thing on your server/web account did not get changed.
                 2. Re:internal error after display_cart
                Author Cathy Roberts on 02-09-2003 at 15:07 (EST)
Hi Bill.
I have replaced all class files(binary) and and & chmod 755), upgrading to 3.5. and checked through troubleshooting - Same problem. did test script correctly (text/chmod 755) and get same internal error at

Apparently nothing has changed at They wanted to know if there was a cart error log but the only thing I can find is ushop.log in the data file and it is empty.

Thanks for your help,
Kind regards,
                         3. Re:internal error after display_cart
                        Author Bill Weiner on 02-10-2003 at 07:31 (EST)
The problem with running CGI scripts on your server is not related to uShop's class files at all... so don't worry about them.

If you are getting a server error with just the CGI Test script... then that indicates that something on your server changed in regard to your ability to run CGI scripts.

The simple "" script described at:

Is the most basic of Perl scripts in that all it does it output a test HTML page, as you can see by going to the URL of the script on our server:

If that basic Perl script results in a server error on your server, then you should contact your web hosting provider. Tell them that you have a very basic test CGI Script that you can not get to work. They should be able to determine the problem immmediately.

Then upon getting that "" script working, you should be able to apply the same to get the uShop CGI script working.

© 2003 Microburst Technologies, Inc.