uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
qmail" vs. "sendmail

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Nov-21-17 06:52 AM EST
Original Message
qmail" vs. "sendmail
Author Drew on 11-01-2000 at 16:58 (EST)
I've installed the freebie version of uShop on a Linux server, and everything works fine EXCEPT: I get no email notification sent to either me or the customer. I've tried every troubleshooting tip listed, to no avail. My hosting company says that instead of using "sendmail" my server uses "qmail". However, they say that qmail can use a "wrapper" to emulate sendmail, and that should do the trick. But they don't explain exactly how to do it. Any help here?? I really like uShop, and will definitely upgrade to a purchased version...once I get this snag figured out. HELP!!!
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: "qmail" vs. "sendmail" Bill Weiner, 2000-11-01 19:04:23 (1)
  Me Too EmporerEJ, 2000-11-16 02:58:09 (2)
            RE: Me Too Bill Weiner, 2000-11-16 07:54:14 (3)

Messages In This Discussion
         1. RE: "qmail" vs. "sendmail"
        Author Bill Weiner on 11-01-2000 at 19:04 (EST)
I believe you can use qmail instead of sendmail by simply specifying the path of qmail on your server instead of sendmail. That is, instead of specifying the $sendmail_path configuration question in the uShop CGI script as something like this:

$sendmail_path = "/usr/lib/sendmail";

Just specify it as something like this:

$sendmail_path = "/usr/lib/qmail";

... where the "/usr/lib/qmail" is whatever the path to qmail on your server is.
TABLE OF CONTENTS
         2. Me Too
        Author EmporerEJ on 11-16-2000 at 02:58 (EST)
How did you fix this?
You are describing my problem, but I'm on a win2k server.
it uses mail.exe, and the cart acts like it's all good, but doesn't send the customer or me the order.
TABLE OF CONTENTS
                 3. RE: Me Too
                Author Bill Weiner on 11-16-2000 at 07:54 (EST)
If you are trying to use "qmail" instead of "sendmail".... then try removing the "-n" as described at this posting:

http://www.uburst.com/dcforum/ushop_cgi/106.html

But "qmail" is more of a UNIX server thing...

If you have a Windows server and the built-in SOCKETS and BLAT email options are not working..... then I would suggest submitting a support request (if you have a license number) or just sending an email to support@uburst.com (if you are using one of the trial versions). We have versions of the uShop scripts that use of various other email techniques for various servers/mail programs.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.