uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Coupons not working

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Nov-18-17 03:41 AM EST
Original Message
Coupons not working
Author David Futcher on 09-26-2000 at 03:34 (EST)
I've updated to Ushop v3.10, and tonight tried creating the first coupon for my store. However, I'm getting no indication that anything is happening!

I'm trying to trigger the coupon with a link, instead of entering a code on the order form (everyone kept asking how they could get a coupon when it was on the order form!). You can see the page I'm trying to link from at http://www.futcher.com/nameflag/prize-winner.html

I'm trying to give the user a $13.00 discount on their order. However, I don't see that happening anywhere in the order process.

Any hints??? Is there another update that adresses this issue?

Thanks,

David Futcher
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  Coupons not working David Futcher, 2000-09-26 03:36:00 (1)
            RE: Coupons not working Bill Weiner, 2000-09-26 13:02:07 (2)
                 Re: Coupons not working David Futcher, 2000-09-27 00:55:39 (3)

Messages In This Discussion
         1. Coupons not working
        Author David Futcher on 09-26-2000 at 03:36 (EST)
By the way, just to save you a trip to the site, the syntax I used for my link was the following:

http://www.flagline.com/cgi-bin/ushop.pl?coupon=NTF&url=http://www.flagline.com/countries.html

Thanks again...
TABLE OF CONTENTS
                 2. RE: Coupons not working
                Author Bill Weiner on 09-26-2000 at 13:02 (EST)
I think there may be two issues that may be contributing to the problem:

1) I noticed that you commented out the entire "coupon" section on your "order_template.html". I'm pretty sure that if you are going to use coupons at all, then you will need to put the "coupon_number" input field somewhere on your order form.... so that the "coupon_number" can be POSTed with all of the other fields on the order form. If the coupon was already set by linking to the ushop.pl script with the "coupon" keyword (as you are doing)... uShop will automatically handle filling in that coupon field for the customer. So as one part of the fix, try leaving that "coupon_number" input field somewhere on the order form.

2) The reason I say there may be another problem is due to the fact that I'm pretty sure that even though you have the "coupon_number" field commented out, uShop should still be setting the "value" of that commented-out field. From looking at the source of your order page, however, it appears that the "coupon_number" value is still set to "". So, what may be happening is that the coupon cookie is being set when you link to the script at:

http://www.flagline.com/cgi-bin/ushop.pl?coupon=NTF&url=http://www.flagline.com/countries.html

However, during the order process, that "coupon" cookie does not have permission to be read from your secure script at:

https://www2.addr.com/~uep/cgi-bin/ushop.pl

That is, since the public and secure domains vary by more than just "http" and "https":

www.flagline.com

and

www2.addr.com

The script at "www2.addr.com" does not have permission to read the cookie set by the script at "www.flagline.com".

To get around this type of problem, we are currently working on an additional module that will handle when the domain names differ ... and hope to have this module available soon. In the meantime, however, perhaps you can try linking via your secure URL:

https://www2.addr.com/~uep/cgi-bin/ushop.pl?coupon=NTF&url=http://www.flagline.com/countries.html

-----

On a side note (unrelated to the above problem), while looking at your site, I noticed that you are using a codebase of:

CODEBASE="./u3/classes/"

instead of the default codebase of:

CODEBASE="../classes/"

This is ok, but be sure to set the special "codebase" parameter of your uShopOrderButton applet:

param name="codebase" value="./u3/classes/"

... otherwise, you may run into some browser incompatibility problems.
TABLE OF CONTENTS
                         3. Re: Coupons not working
                        Author David Futcher on 09-27-2000 at 00:55 (EST)
Bill,

Thanks for the great help here. I changed all of the above items you suggested. On my order-template.html form, I just made the "coupon_number" field a hidden input field to keep from having it display on all orders (and therefore unnecessarily excite any skinflint customers!)

Thanks again,

Dave
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.