uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Problems with internal server error after cc no.

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Nov-18-17 05:24 AM EST
Original Message
Problems with internal server error after cc no.
Author Jake Bryant on 11-02-2001 at 10:22 (EST)
After the user enters their CC information, I get an internal server error. Can't think of what this could be caused by. Permissions are set correctly on the data directory, no illegal referrer issues (anymore). Any ideas? feel free to check it out at www.pittsburghplastics.com. On the main order page (click the red button on the left of index.html), click the green checkout button (currently the only way to initiate the order process). thx

-jake
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Problems with internal server error after cc no. Joseph Pishgar, 2001-11-02 13:50:35 (1)
            Well, I thought I had it. Jake Bryant, 2001-11-03 14:38:34 (2)
                 RE: Well, I thought I had it. Joseph Pishgar, 2001-11-05 16:31:53 (3)

Messages In This Discussion
         1. RE: Problems with internal server error after cc no.
        Author Joseph Pishgar on 11-02-2001 at 13:50 (EST)
Hello Jake,

Going to your site at www.pittsburghplastics.com, and adding two turbie-twists and checking out, I finalized my test order without a hitch. The only noticable difficulty was the secure server/insecure server crossover. Recheck your ushop.pl settings and verify that the pathnames are correct. Additionally, if it is causing problems for you in Netscape, try turning off the Page Referral Validation (using IE, log into your control panel and check under Miscelleneous settings).

Hope this helps.

Regards,
Joseph Pishgar
Microburst Technologies, Inc.
www.uburst.com
TABLE OF CONTENTS
                 2. Well, I thought I had it.
                Author Jake Bryant on 11-03-2001 at 14:38 (EST)
I thought everything was working fine, and now, I have noticed a problem that I'm not sure how to remedy. It seems that there are 2 ways to initiate the order process at this site. One - click the green checkout button on any product page or the main order page. Or, click on the picture of a shopping cart on any page (below the main link menu on the left) and then click "Begin Order PRocess".

It seems as though there is no error when ordering via the first method, but when I tried the second, I got that illegal referrer error. Any ideas on what's wrong? I presume I've referred to the site via its IP addy in some script somewhere (when the rest of the referrals to the site or secured site are done using the actual domain names). I just don't know where. Please help.
TABLE OF CONTENTS
                         3. RE: Well, I thought I had it.
                        Author Joseph Pishgar on 11-05-2001 at 16:31 (EST)
Hello Jake,

The second way doesn't give me an error, just a mixed security zone type of message on the *first* attempt. The second attempt on the second method is fine. Try moving shopping_cart.htm over to your secure server and linking it from the little shopping cart icon on the bottom left hand corner of the pages, and see if that works for you.

Regards,
Joseph Pishgar
Microburst Technologies, Inc.
www.uburst.com
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.