uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
uShopInput5, uShopCart1

Knowledge Base Lobby : uShop Support Conference : General Questions
Nov-19-17 11:14 AM EST
Original Message
uShopInput5, uShopCart1
Author wpriley on 01-06-2003 at 01:05 (EST)
LAST EDITED ON Jan-06-03 AT 09:04 PM (EST)


Hi, I am just setting up a new eCommerce site and am planning to use uShop. This will be my first experience with your applets and scripts. So far I love the applets ease of use and the ability to wrap my own HTML around them. I have two uShop pages set up on a prototype staging site.

uShopInput5 and uShopCart3: http://ezinger.com/cgt/000123.htm
uShopCart1: http://ezinger.com/cgt/cgt_sc.htm

Question relative to the background color at load initiation on both uShopInput5 and uShopCart1 (both background colors are set to #FFFFFF). With both applets, the prior background does not clear to white until focus is forced by mouse or keyboard. You can see a screen capture of uShopCart1 with the background from the prior screen underlaying the two remove buttons at: http://ezinger.com/cgt/ushop_sample.gif. This problem occurs in IE 6 and Mozilla 1.1 but does not occur in Netscape 4.78 or Optra 6.01. Is there a parameter or other method I can use to universally force the background to initiate to #FFFFFF at initial display (prior to forcing focus)?

Also relative to uShopCart1:

1) Is there a method to select the cart font? I'd like to use a san-serif font like Arial rather than Times Roman.

2) Is there a method to right justify the "QTY" and "PRICE" columns?

Thanks for your help. I look forward to using these great applets on this new site and in future projects as well.

Pat Riley
505-797-9072
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: uShopInput5, uShopCart1 Bill Weiner, 2003-01-07 06:45:49 (1)
            Suggested fix didn't work wpriley, 2003-01-07 12:45:23 (2)
                 RE: Suggested fix didn't work Bill Weiner, 2003-01-08 06:55:07 (3)

Messages In This Discussion
         1. RE: uShopInput5, uShopCart1
        Author Bill Weiner on 01-07-2003 at 06:45 (EST)
In regard to the background overlaying problem, usually that problem on IE is caused by the applet being place in an HTML Table without specifying a specific HEIGHT/WIDTH for the Table Cell (< TD >) in which the applet is located. That is, if you are using an HTML TABLE to arrange the applet on that page, make sure you specify the WIDTH and HEIGHT of that table cell such that it is larger than the applet. For example, if the applet's WIDTH and HEIGHT is 200 x 35, then maybe set the HTML table cell's WIDTH and HEIGHT to 205 x 40:

< TD WIDTH=200 HEIGHT=40 >

In regard to changing the font of the uShopCart1 applet, unfortunately we have to use a fixed-width font (Courier) at this time... in order to make sure all of the columns in the cart line up.

In regard to right-justifying the QTY and PRICE columns of the uShopCart1, unfortunately, there are no options built-in to the applet to do that at this time.

We are, however, working on several improvements to the Cart applets and hope to have them available in an upcoming release. (Release date TBD.)
TABLE OF CONTENTS
                 2. Suggested fix didn't work
                Author wpriley on 01-07-2003 at 12:45 (EST)
LAST EDITED ON Jan-07-03 AT 12:51 PM (EST)


LAST EDITED ON Jan-07-03 AT 12:47 PM (EST)

Hi, thanks for your quick response regarding background overlay problem with uShopCart1 in IE6 (the problem also occurs in Mozilla). My applet was in a sized element previously but it was sized to exactly match the applet. Per your suggestion, I've since increased the table entry by 6 in both width and height but still get the same overlay problem. Note that I also placed a background color in the table cell using both a background color and background image.

I'd very much appreciate any other suggestion you can offer. My prior posting has a link to the staging area for both applets (I've only changed uShopCart1 to date). You can see an example by going to the link below and clicking on the "Shopping cart" button on the right navigation bar:

http://www.ezinger.com/cgt/000123.htm

I'd appreciate any further suggestions you could offer. Thanks for your continued help and support.
TABLE OF CONTENTS
                         3. RE: Suggested fix didn't work
                        Author Bill Weiner on 01-08-2003 at 06:55 (EST)
That's really weird considering the image that is "left over" in your "ushop_sample.gif" screenshot, is actually from the previous HTML page. That leads me to believe that it is some sort of a memory problem with your computer... and maybe those particular browsers are pushing the memory on your computer.

I checked out your site with IE 6.0.26, Netscape 4.73 and even memory hog Netscape 6.0... all running at the same time even... and still did not see the problem you captured in your screen shot. (I don't have Mozilla installed on this computer at the moment so I couldn't check it out with Mozilla at this time.)

Anyway, I did take a look at your HTML... and that all looks very good. I don't really see anything wrong there that would cause such a problem.... but since you have a couple tables within the 3rd row of your main table... it may not hurt to try setting the width of the table cell that contains the other tables... to something like 610. That is:

Change the second table cell in the third row from:

< TD align="center" valign="top" bgcolor="#FFFFFF" background="cgt_wh.gif" >

To:

< TD width="610" align="center" valign="top" bgcolor="#FFFFFF" background="cgt_wh.gif" >

And maybe that would help your browser draw/size/refresh the tables properly.

If that doesn't work, then maybe something could be done with a JavaScript function that get's called via "onLoad".

But again, I'm not seeing the problem on any of my browsers so I can't really try it out myself.

I hope this information helps.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.