uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Problem with ISP

Knowledge Base Lobby : uShop Support Conference : General Questions
Nov-20-17 10:41 AM EST
Original Message
Problem with ISP
Author joatt on 04-29-2002 at 04:51 (EST)
Bill
This is not a problem with my Shopping Cart but a problem with my ISP. I am aware that what I am asking is most likley outside the limits of your support system but would appreciate any assistance you are willing to give as my techinal level in this matter is almost zero. Re organised directory structure as per your instructions,works fine on my PC, uploaded in binary to server, rang ISP to get file structure changed to same and set permissions .View site online, no images or shopping cart. Call into ISP and spend 2 hours with owner who is unable to get any files in the other directorys to be viewable other than /onshop/ in this structure setup. The structure on the server is ( I also have a second un related site on this server )
home/t/timmins/autocraft/public_html/..
/onshop/public_html/cgi/classes/images_os/images/onshop/. his server setup is Unix /Apache/FreeBSD 4.3 Site works ok minus Shopping Cart if files are placed in /public_html/, He thinks the problem is related to Apache permission structure I am not being too hard on him as he just lost his IT pro and is strugling with this a little as his knowledge level is not 100
%. on Apache Any thoughts on this are appreciated.
Regards
David Timmins
PS.Sorry for any confusion I posted a similar request to this to the wrong thread a few days back
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Problem with ISP Bill Weiner, 2002-04-30 06:44:28 (1)
            Re ISP joatt, 2002-04-30 18:34:55 (2)
                 RE: Re ISP Bill Weiner, 2002-05-01 05:41:42 (3)
                      ISP Problem joatt, 2002-05-02 23:27:25 (4)

Messages In This Discussion
         1. RE: Problem with ISP
        Author Bill Weiner on 04-30-2002 at 06:44 (EST)
The problem may be that it looks like the "classes" are in a "cgi" subdirectory? Often files in the "cgi" directory (and any subdirectory of the "cgi" directory) are not viewable.

Try putting your "classes" directory in your "public_html" directory.... and use a directory structure like this:

Create a directory such as:

/public_html/store/

... and put all your HTML pages in that directory.

Create another directory such as:

/public_html/classes/

... and put all of your "class" files in that directory.

Basically keeping all HTML, class, and image files in subdirectories of your "public_html" directory.
TABLE OF CONTENTS
                 2. Re ISP
                Author joatt on 04-30-2002 at 18:34 (EST)
Bill
My directory structure is already as you have suggested,within my public_html folder is my classes folder containing all relevent classes files,store folder containing all store html files,images folder and all img files,cgi folder with all relevent files ect. code base../
Regards David Timmins
TABLE OF CONTENTS
                         3. RE: Re ISP
                        Author Bill Weiner on 05-01-2002 at 05:41 (EST)
But from the directory path you mentioned:

/onshop/public_html/cgi/classes/images_os/images/onshop/

... it looks like they are in a "cgi" subdirectory of your "public_html" folder.

Having those HTML/classes directories under the "cgi" directory could be causing the problem.

So try even a simple test of moving ... say.... and image from one the subdirectories to somewhere outside of the "cgi" directory. Then see if you can go to the URL of the image and see it. If that works, then move the other HTML and classes directories outside of your "cgi" directory... perhaps in the directory structure that I mentioned in the previous post.
TABLE OF CONTENTS
                                 4. ISP Problem
                                Author joatt on 05-02-2002 at 23:27 (EST)
Bill
There are no other files or directorys with in the cgi directory other than those that came with Ushop ..perhaps I presented it in a manner that made it appear that way. But moving along, I went back to my ISP who created a new directory off the server root.. server/onshop/public_html ..replacing the original set up of.. server/t/timmins/onshop/public_html/onshop..etc uploaded to server and placed my store html files in public_html folder then all other relevent folders as a sub directory of public_html. I am aware that as I had changed the file/folder structure from your standard set up it was necessary to change the classes structure from ../classes to classes, when testing (www.nelsonbay.com/~onshop this URL temporary for testing) on line it all functions ok . Should I leave the set up as is or should I try to achieve the the standard set up you recommend.An interesting note to all this problem my ISP guy, on advise from another tech sugests that the main problem appears to be his Apache configuration not allowing a search beyond the public_html folder for an index.html file as was the case when placing my store in a sub folder to the public_html folder, does that make sense?
Regards David Timmins
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.