uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Problem with clearing affiliate log...

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Nov-17-17 07:41 PM EST
Original Message
Problem with clearing affiliate log...
Author Matt on 06-07-2002 at 10:31 (EST)
As posted earlier in this forum, someone else mentioned problems clearing the affiliate log. I too, am having problems clearing the affiliate log!

Is uBurst working on a fix for this? (*NOTE: in THIS release, not to be included in the next release?)

Thanks in advance!
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  Also.... another question Matt, 2002-06-07 11:25:28 (1)
            Nevermind... found it.... Matt, 2002-06-07 22:24:33 (2)
                 RE: Nevermind... found it.... Bill Weiner, 2002-06-10 05:16:19 (3)
                      Sure isn't Matt, 2002-06-10 10:47:34 (4)
                           RE: Sure isn't Bill Weiner, 2002-06-11 05:10:22 (6)
                                Works Beautifully now! Matt, 2002-06-11 09:34:05 (7)
                      here's the other reference to problem Matt, 2002-06-10 12:03:02 (5)

Messages In This Discussion
         1. Also.... another question
        Author Matt on 06-07-2002 at 11:25 (EST)
Also, isn't there a way for an affiliate to login to see what sales they have accumulated? I thought I read somewhere there was something stated about having this already or making this available? (Nothing in the developer page either)

As for the order reader, is this configurable for this to work too?

Thanks again,
Matt
TABLE OF CONTENTS
                 2. Nevermind... found it....
                Author Matt on 06-07-2002 at 22:24 (EST)
Nevermind... found it....

But STILL need to find out about CLEARING affiliate log?? What's the deal with that??
TABLE OF CONTENTS
                         3. RE: Nevermind... found it....
                        Author Bill Weiner on 06-10-2002 at 05:16 (EST)
You can clear the affiliate log from the control panel under "Affiliate Tracking - Clear Log".

Is that not working for you?
TABLE OF CONTENTS
                                 4. Sure isn't
                                Author Matt on 06-10-2002 at 10:47 (EST)
Bill,

I tried clearing the log from the affiliate control section, Clear Log, where it asks for the date in the format of MM/DD/YY.

I enter the date, and there is nothing that happens, I have to manually FTP into the directory and delete the log.

There was another post in here somewhere that someone else had the same issue. I didn't see anything about it though, so I decided to post my problem too...

Please advise.

Thanks,
Matt
TABLE OF CONTENTS
                                         6. RE: Sure isn't
                                        Author Bill Weiner on 06-11-2002 at 05:10 (EST)
Ok, what I believe is happening is that when we updated the order date format to have a 4-digit year, the date format in the affiliate log also got updated, but the logic in the affiliate clear method was not updated. So here is a way to correct that:

STEP 1: Make a backup of your ushop-lib.pl script... just in case.

STEP 2: Open your ushop-lib.pl script with any text editor such as WordPad.

STEP 3: Do a search on the following line:

$clear_year += 100;

STEP 4: Change that line to:

$clear_year += 2000;

STEP 5: Save the script... as TEXT if your editor asks... and try it out!
TABLE OF CONTENTS
                                                 7. Works Beautifully now!
                                                Author Matt on 06-11-2002 at 09:34 (EST)
Thank Bill... seems to work just perfect now! Almost ready to roll out the store now, just tedious database work now!

Thanks again to the support team - KUDOS~

Matt
TABLE OF CONTENTS
                                 5. here's the other reference to problem
                                Author Matt on 06-10-2002 at 12:03 (EST)
http://www.uburst.com/dcforum/ushop_cgi/150.html
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.