uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
CGI/perl.exe

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Nov-21-17 06:19 PM EST
Original Message
CGI/perl.exe
Author Brad Giosa on 07-07-2000 at 17:02 (EST)
ok i am running my own win2k server and i have my chopping cart in wwwroot/cgi-bin. everything is contained inn that folder. i downloaded Activeperl. and i set the script properties in IIS 5.0 to .pl -->c:perlbinperl.exe and
.cgi---> c:perlbinperl.exe and when ever i try to test my ordering everything works except the command just hangs nothing happens. i even went to the command line and type: perl ushop_cgiscript.cgi (also tried pl) with the cmd=write and all that and all it does is hang nothing happens. is there anyone who can help??
thanks brad giosa
please reply by emailing me bboyizmo@aol.com
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: CGI/perl.exe Bill Weiner, 2000-07-08 08:13:42 (1)
            cgi/perl.exe brad g., 2000-07-08 16:16:30 (2)
                 RE: cgi/perl.exe Bill Weiner, 2000-07-10 06:33:57 (3)
                      perl/cgi mapping brad g, 2000-07-10 10:02:51 (4)
                           RE: perl/cgi mapping Bill Weiner, 2000-07-10 15:13:39 (5)

Messages In This Discussion
         1. RE: CGI/perl.exe
        Author Bill Weiner on 07-08-2000 at 08:13 (EST)
If you've never executed Perl scripts on your server before, I would suggest that you try installing the very basic Perl script described at:

http://www.uburst.com/uStorekeeper/testscript.html

This test script is actually on the reference pages for one of our other products (called uStorekeeper), but the concept is the same. By following the instructions to install this very basic Perl script, you should be able to see how Perl scripts are installed/executed on your server, as well as verify that it is indeed setup properly to execute Perl scripts. Once you get that test script working....installing the uShop CGI script should be much easier.
TABLE OF CONTENTS
                 2. cgi/perl.exe
                Author brad g. on 07-08-2000 at 16:16 (EST)
ok i did everythingng it told me too. still doesn't show a test page. could it be that my iis 5.0 setting are wrong or not installed properly?
in iis 5.0 i have the .pl document point toward c:perlbinperl.exe. is this correct or are my server settings incorrect???
brad
TABLE OF CONTENTS
                         3. RE: cgi/perl.exe
                        Author Bill Weiner on 07-10-2000 at 06:33 (EST)
If the very basic test script doesn't run on your NT server, then the server settings may indeed be wrong. Unfortunately, Iím not really familiar with configuring NT servers, but perhaps this excerpt from someone else configuring an NT server will help:

"For those of us who run our own NT servers, you might consider adding this to your troubleshooting area... If the script tries to download (or is displayed) rather than ran. You say the directory may not be configured to run CGI scripts. And that is true, however the directory must have execute permission, but the site is what must be configured to execute scripts by mapping the perlis.dll to each site that will use it. At site root directory in IIS Console, properties, home directory tab, configuration, App Mappings tab, add. This is true for both IIS 4 on NT 4.0 and IIS5 on Windows 2000 beta."
TABLE OF CONTENTS
                                 4. perl/cgi mapping
                                Author brad g on 07-10-2000 at 10:02 (EST)
i have tried to map the .pl and .cgi files at the root of my dir in iis 5.0 and scripts and executables are enabled, i have the following mapped:
.pl mapped to c:perlbinperlis.dll
.cgi mapped to c:perlbinperlis.dll
the does not download and does not show, it only hangs on my browser as if it is doing something.
TABLE OF CONTENTS
                                         5. RE: perl/cgi mapping
                                        Author Bill Weiner on 07-10-2000 at 15:13 (EST)
Glad to hear you figured out the problem:

http://www.uburst.com/dcforum/ushop_place_order/61.html
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.